Bug 227143 - Editor loses focus to navigator when traversing code (i.e. scroll caret to another method or code element).
Editor loses focus to navigator when traversing code (i.e. scroll caret to an...
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Navigator
7.4
PC Linux
: P3 (vote)
: TBD
Assigned To: Jan Peska
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-07 09:16 UTC by bjblazko
Modified: 2013-05-16 07:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bjblazko 2013-03-07 09:16:19 UTC
Product Version: NetBeans IDE Dev (Build 201303042300)
Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Linux version 3.5.0-17-generic running on amd64; UTF-8; en_US (nb)

- Using "--laf Metal -J-Dnetbeans.plaf.dark.theme=true"

When I have opened a .java or .html file (not tested with others except JavaScript - there it works), the code editor loses focus and the navigator receives it upon movung the caret to another element (class member, method etc.).

Thus, editing the source is interrupted. The very same version works fine on OS X.

Thanks and best regards,
Timo

P.S. I hope this is no duplicate, could not find similar bug description.
Comment 1 bjblazko 2013-03-21 09:38:12 UTC
The issue still exists with dev build 201303192300.

It only happens if you enable multiple tab rows for the editor (Tools -> Options -> Misc -> Windows -> Multi-row tabs).
Comment 2 Jan Peska 2013-03-21 10:07:55 UTC
Thanks for reporting, I'll take a look on it.
Comment 3 Jan Peska 2013-05-15 07:26:18 UTC
Unfortunately I'm not able to reproduce this issue. Can you specify when the editor loses focus in more detail?

My steps:
1. open java file
2. move caret in the java file editor to another method
3. focus stays in the editor window

Have I missed a step?
Comment 4 Jan Peska 2013-05-16 07:33:06 UTC
please reopen ASA detailed info is provided.

Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo