Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 226959 - Incorrect status for Git submodule files
Incorrect status for Git submodule files
Status: RESOLVED DUPLICATE of bug 207067
Product: versioncontrol
Classification: Unclassified
Component: Git
7.2
PC Mac OS X
: P3 (vote)
: 7.3
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 01:07 UTC by ain
Modified: 2013-03-05 08:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Incorrect Git VCS report due to Git submodule (118.93 KB, image/png)
2013-03-04 01:13 UTC, ain
Details
Commit dialogue fails to detect new sobmodule (132.97 KB, image/png)
2013-03-04 01:28 UTC, ain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ain 2013-03-04 01:07:09 UTC
How to reproduce:
1. Add a submodule to a cloned Git repository
2. Commit everything

What happens: 
1. Files in the submodule folder show up as Added.
2. After removing a submodule (git rm --cached submodule), all files still show up as Added even if the folder gets removed.

What should happen: all files in a submodule should be disregarded.

I know there have been tickets on this topic before and unfortunately I do agree that one can't work with submodules in NetBeans right now. Esp. in big projects it's a blocker.

Platform specs:
Product Version: NetBeans IDE 7.2 (Build 201207171143)
Java: 1.6.0_41; Java HotSpot(TM) 64-Bit Server VM 20.14-b01-445
System: Mac OS X version 10.8.2 running on x86_64; MacCentralEurope; et_EE (nb)
User directory: /Users/ain/Library/Application Support/NetBeans/7.2
Cache directory: /Users/ain/Library/Caches/NetBeans/7.2
Comment 1 ain 2013-03-04 01:13:04 UTC
Created attachment 132126 [details]
Incorrect Git VCS report due to Git submodule
Comment 2 ain 2013-03-04 01:28:35 UTC
Created attachment 132127 [details]
Commit dialogue fails to detect new sobmodule
Comment 3 Ondrej Vrabec 2013-03-04 06:33:21 UTC
i suggest upgrading to 7.3, some issues regarding submodules were fixed in that release: e.g. #224524
Comment 4 ain 2013-03-04 08:47:29 UTC
I'd love to upgrade but I'm dependant on Rails support in 7.2. Any workarounds?
Comment 5 ain 2013-03-05 00:46:04 UTC
Reopening for 7.3. I've tested it on the latest NetBeans release (as we communicated on email), same failure, throws "No files available for commit".

Platform specs:
Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.6.0_41; Java HotSpot(TM) 64-Bit Server VM 20.14-b01-445
Runtime: Java(TM) SE Runtime Environment 1.6.0_41-b02-445-11M4107
System: Mac OS X version 10.8.2 running on x86_64; MacCentralEurope; et_EE (nb)
User directory: /Users/ain/Library/Application Support/NetBeans/7.3
Cache directory: /Users/ain/Library/Caches/NetBeans/7.3
Comment 6 Ondrej Vrabec 2013-03-05 08:48:21 UTC
> Reopening for 7.3. I've tested it on the latest NetBeans release (as we communicated on email), same failure, throws "No files available for commit".
This is specific to submodules and must be fixed as part of #207067. Simply initialize submodules on commandline and after that (assuming you restart the IDE because you basically create another local Git repository externally) committing modifications in submodule's *files* will work.

*** This bug has been marked as a duplicate of bug 207067 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo