Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 226860 - [74cat] Cannot deploy JavaFX projects with Preloader to WebStart and Run in Browser
[74cat] Cannot deploy JavaFX projects with Preloader to WebStart and Run in B...
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Deployment
7.3
PC All
: P3 (vote)
: 8.0
Assigned To: Roman Svitanic
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-28 21:01 UTC by sviyer
Modified: 2013-12-20 08:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
java ws trace (56.44 KB, application/octet-stream)
2013-02-28 21:01 UTC, sviyer
Details
NB Project files (189.19 KB, application/zip)
2013-02-28 21:03 UTC, sviyer
Details
Webstart runtime error display (52.57 KB, image/jpeg)
2013-11-22 05:31 UTC, Lou Dasaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sviyer 2013-02-28 21:01:24 UTC
Created attachment 132026 [details]
java ws trace

I am running NB7.3 on Vista
on
java version "1.7.0_15"
Java(TM) SE Runtime Environment (build 1.7.0_15-b03)
Java HotSpot(TM) Client VM (build 23.7-b01, mixed mode, sharing)

Using the IDE interface I created a new JavaFX app with a preloader (check the box to generate a preloader with the app).

NB generates the code and adds necessary javafx and javaws jar files to the compile path.

Running the project standalone works.
Running the project as webstart (with default settings on signing etc) generates number of exceptions in trace file (see full trace attached)

----------------
basic: Error parsing C:\\Users\\PETERC~1\\AppData\\Local\\Temp\\javaws2. Try to parse again with codebase from LAP
java.net.MalformedURLException: no protocol: 
--------------------
network: SyncFileAccess.openLock: handled OverlappingFileLockException, remainint TO : 10000
------------------------
java.io.FileNotFoundException: \C:\DevFiles\Projects\JavaFX\TestFXApp\dist\lib\lib\TestFXApp-Preloader.jar
java.io.FileNotFoundException: \C:\DevFiles\Projects\JavaFX\TestFXApp\dist\lib\lib\jfxrt.jar
java.io.FileNotFoundException: \C:\DevFiles\Projects\JavaFX\TestFXApp\dist\lib\lib\deploy.jar
java.io.FileNotFoundException: \C:\DevFiles\Projects\JavaFX\TestFXApp\dist\lib\lib\javaws.jar
java.io.FileNotFoundException: \C:\DevFiles\Projects\JavaFX\TestFXApp\dist\lib\lib\plugin.jar
---------------------------------
The TestFXApp-Preloader.jar should be looked for under dist\lib and not dist\lib\lib
And correct me if I am wrong, the other 3 files should be available with the java/javafx/javaws  runtime ??? 
---------------------------------------------

Running the project as embedded (via browser) launches the browser and nothing happens. Browser page stays blank with the startup gif animation.
Comment 1 sviyer 2013-02-28 21:03:31 UTC
Created attachment 132027 [details]
NB Project files
Comment 2 Lou Dasaro 2013-09-17 09:17:04 UTC
Tested extensively using NB 7.3 with no patches,  and NB 7.4 DEV 201309112301.
This bug applies to WebStart and Run in Browser. Standalone apps build/run just fine in all cases.

USING REPORTER'S PROJECT FILES, I was able to build and run successfully as WebStart and in Browser. However, a subsequent attempt to run caused the following error to occur: 

"JavaFX application could not launch due to system configuration..."

WORKAROUND: Due to an error in the Reporter's Project, subsequent to Running the reporter's NB Projects, you must CLEAN the projects or otherwise force them to recompile before you can Run the main project again. Otherwise, you'll get the above error.  Required for all OS's I tested except Windows 8 (go figure!).

ON WINDOWS 8: No apparent problem in NB 7.3 or 74 RC1 (proposed). Fresh install of both NB over fresh JDK 7u40 may be a consideration(?). Using Reporter's scenario, In the IDE I created a new Project->JavaFX app with a preloader (checked the box to generate a preloader with the app). I was able to build and run successfully as WebStart and in Browser (IE) repeatedly with NO errors. 

ON WINDOWS 7 and UBUNTU 12.04: Using Reporter's scenario, project ran successfully after creation ONCE, and then FAILED TO RUN. MUST USE WORKAROUND - force compilation. Something must(?) be wrong with the ant build for Preloader projects.

Therefore I am adding this to 74cat, and changing the title to something more meaningful (was: "Multiple exceptions in javaws trace file"). The Priority should probably be bumped to P2, but there is an annoying workaround...

My test configurations:
Product Version: NetBeans IDE 7.3 (Build 201302132200)
Updates: Updates available to version NetBeans 7.3 Patch 2 (did not patch)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)

Product Version: NetBeans IDE 7.3 (Build 201302132200)
Updates: Updates available to version NetBeans 7.3 Patch 2 (did not patch)
Java: 1.7.0_25; Java HotSpot(TM) Client VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)

Product Version: NetBeans IDE 7.4 RC1 (Build 201309112301)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b40
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)

Product Version: NetBeans IDE 7.4 RC1 (Build 201309112301)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)
and Ubuntu 12.04 (64-bit) (Linux version 3.2.9-53-generic running on amd64; UTF-8, en_US (nb)

Also found anomaly present with NB 7.3.1 on Windows 7.
Comment 3 Lou Dasaro 2013-09-24 07:49:55 UTC
Revised: Project will not RUN a second time after running FROM NetBeans in Web Start or Run in Browser. Also applies to Windows 8 environment.  Changing Version to 7.4 to indicate the anomaly still exists, though applies to both 7.3, 7.3.1 and 7.4 RC1 builds of NetBeans (and probably 7.3.1)

Note that the artifacts in /dist will run multiple times without error. The problem exists when running FROM NetBeans 7.3.x or 7.4 RC1

Product Version: NetBeans IDE 7.4 RC1 (Build 201309162201)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)
Comment 4 Roman Svitanic 2013-11-21 13:36:08 UTC
I am not able to reproduce the issue on the current dev build. Could someone please try to reproduce issue on the latest dev build? Thanks!
Comment 5 Lou Dasaro 2013-11-22 05:08:13 UTC
Unable to test with latest dev build due to Bug 237920

I am unable to create a JavaFX Project with preloader!
In fact, I can't create or open a JavaFX project at all!
Comment 6 Lou Dasaro 2013-11-22 05:31:31 UTC
Created attachment 142467 [details]
Webstart runtime error display

Error still occurs as of Product Version: NetBeans IDE Dev (Build 201311130002)
Updates: Updates available
Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)
Comment 7 Roman Svitanic 2013-11-22 10:41:27 UTC
(In reply to mr_lou_d from comment #5)
> Unable to test with latest dev build due to Bug 237920
> 
> I am unable to create a JavaFX Project with preloader!
> In fact, I can't create or open a JavaFX project at all!

Thank you for trying.

Please try to download the latest dev build and start it with clean userdir, I had no problems creating JavaFX App with build:

Product Version: NetBeans IDE Dev (Build 201311220002)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

If it won't help, then we should wait for fixing of above-mentioned issue.

Thanks!
Comment 8 Roman Svitanic 2013-12-04 12:59:52 UTC
I am closing this issue as works for me. It is possible to run JavaFX application both as a webstart or in browser:

Product Version: NetBeans IDE Dev (Build 201312040002)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18

If the issue still occurs, please reopen it with (updated) steps to reproduce. Thanks!
Comment 9 Lou Dasaro 2013-12-04 17:42:27 UTC
Roman: Problem continues to occur in NB 7.4-patch1, under Windows 8.1. I have not seen it (yet) in DEV as of 20131126.

If you repeatedly run or debug, eventually NB "forgets" to create a /dist directory and put the html file there, and then you get a java.io.filenotfounderror error (from FireFox) Firefox can't find the file at /C:/Users/Lu/Documents/NetBeansProjects/JavaFXApplication26/dist/JavaFXApplication26.html

I'll see if I can't work up a specific, duplicable test case and will reopen then.
Comment 10 Lou Dasaro 2013-12-20 08:40:58 UTC
This appears to have been fixed in 7.4 Patch 2, so am verifying it as such. 

See also Bug 239233


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo