Bug 226677 - AssertionError at com.sun.tools.javac.util.Assert.error
AssertionError at com.sun.tools.javac.util.Assert.error
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.3
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-25 18:38 UTC by gteichrow
Modified: 2015-09-17 11:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.84 KB, text/plain)
2013-02-25 18:38 UTC, gteichrow
Details
stacktrace (3.84 KB, text/plain)
2013-02-27 15:11 UTC, Jesse Glick
Details
stacktrace (3.84 KB, text/plain)
2013-03-21 16:27 UTC, Petr Jiricka
Details
stacktrace (3.84 KB, text/plain)
2013-05-22 13:35 UTC, Petr Jiricka
Details
stacktrace (3.98 KB, text/plain)
2013-07-01 08:51 UTC, Exceptions Reporter
Details
stacktrace (3.84 KB, text/plain)
2013-07-10 08:00 UTC, Petr Cyhelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gteichrow 2013-02-25 18:38:50 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-10156-on-20130124)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.14-b01-445, Java(TM) SE Runtime Environment, 1.6.0_41-b02-445-11M4107
OS: Mac OS X

User Comments:
gteichrow: After a fresh restart, I received this on kicking off a clean-build of the project.




Stacktrace: 
java.lang.AssertionError
   at com.sun.tools.javac.util.Assert.error(Assert.java:126)
   at com.sun.tools.javac.util.Assert.check(Assert.java:45)
   at com.sun.tools.javac.code.Annotations.setDeclarationAttributesWithCompletion(Annotations.java:124)
   at com.sun.tools.javac.comp.MemberEnter.actualEnterAnnotations(MemberEnter.java:1070)
   at com.sun.tools.javac.comp.MemberEnter.access$400(MemberEnter.java:69)
   at com.sun.tools.javac.comp.MemberEnter$5.enterAnnotation(MemberEnter.java:1009)
Comment 1 gteichrow 2013-02-25 18:38:51 UTC
Created attachment 131859 [details]
stacktrace
Comment 2 Jesse Glick 2013-02-27 15:11:26 UTC
Created attachment 131971 [details]
stacktrace

Scanning NB hudson module and related.
Comment 3 Petr Jiricka 2013-03-21 16:27:40 UTC
Created attachment 132916 [details]
stacktrace

Compiling code.
Comment 4 Petr Jiricka 2013-05-22 13:35:14 UTC
Created attachment 134746 [details]
stacktrace

Not sure, IDE was idle.
Comment 5 Exceptions Reporter 2013-07-01 08:51:14 UTC
Created attachment 136528 [details]
stacktrace

Happened while background scanning due to the switching of the project group
Comment 6 Petr Cyhelsky 2013-07-10 08:00:24 UTC
Created attachment 136920 [details]
stacktrace

doing nothing
Comment 7 Martin Balin 2015-09-17 11:23:12 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo