Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 22666 - [completion] UI of auto completion in "import" line
[completion] UI of auto completion in "import" line
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
3.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 51603 (view as bug list)
Depends on:
Blocks: 152194
  Show dependency treegraph
 
Reported: 2002-04-22 17:45 UTC by pepperpusher
Modified: 2009-05-12 09:49 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pepperpusher 2002-04-22 17:45:35 UTC
UI doesn't function as smooth as JBuilder's.
type import[space] - popup appears, select with arrows & 
press enter. The auto-completion module should check 
whether the last one is a package or class. If package it 
should add "." right after it and open the next popup, if 
class then add ";".
Comment 1 Jan Chalupa 2002-04-22 18:41:23 UTC
Sounds like a request for enhancement to me, not an actual defect.
Comment 2 pepperpusher 2002-06-18 11:10:00 UTC
Whatever, don't be a politician, just do it. bythe time you read this
you could have fixed it, excuse me, enhanced it...

Comment 3 Marek Grummich 2002-07-22 09:55:53 UTC
Set target milestone to TBD
Comment 4 Marek Grummich 2002-07-22 09:58:36 UTC
Set target milestone to TBD
Comment 5 psuk 2004-03-23 19:15:50 UTC
Changing subcomponent to "code completion"

Comment 6 Milan Kubec 2005-06-15 11:29:22 UTC
Having import CC adding '.' after adding package would be very nice feature.
Comment 7 Milan Kubec 2005-06-15 11:31:25 UTC
*** Issue 51603 has been marked as a duplicate of this issue. ***
Comment 8 Quality Engineering 2008-10-22 05:01:48 UTC
Integrated into 'main-golden', will be available in build *200810220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5e7b18d8ace0
User: Dusan Balek <dbalek@netbeans.org>
Log: Minor modification - code completion adds dot after package names - see issue #22666.
Comment 9 Dusan Balek 2009-05-12 09:49:10 UTC
Already implemented.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo