Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 226436 - Netbeans shows different results in 'Show Changes' in Project and Favorites
Netbeans shows different results in 'Show Changes' in Project and Favorites
Status: RESOLVED DUPLICATE of bug 159543
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.3
PC Linux
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-21 08:13 UTC by tomzi
Modified: 2013-02-21 08:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (107.12 KB, text/plain)
2013-02-21 08:13 UTC, tomzi
Details
Screenshot 1 (60.56 KB, image/png)
2013-02-21 08:26 UTC, tomzi
Details
Screenshot 2 (39.87 KB, image/png)
2013-02-21 08:26 UTC, tomzi
Details
Screenshot 3 (66.87 KB, image/png)
2013-02-21 08:26 UTC, tomzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2013-02-21 08:13:44 UTC
When I click on a maven project under 'Projects' and do 'Show Changes' I get different (wrong) results as when I click on the exact same folder of the maven project in 'Favorites'. 

See screenshots


Product Version = NetBeans IDE 7.3 RC2 (Build 201302050851)
Operating System = Linux version 3.5.0-24-generic running on amd64
Java; VM; Vendor = 1.7.0_15
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Comment 1 tomzi 2013-02-21 08:13:49 UTC
Created attachment 131647 [details]
IDE log
Comment 2 Ondrej Vrabec 2013-02-21 08:24:00 UTC
What screenshot?
Anyway, the result should be correct. Project node is a logical node that includes its source groups (src, tests, external libraries etc.) and *not* the project folder. So the results may be different because both the times you're trying to look for changes of different folders.
Comment 3 tomzi 2013-02-21 08:26:00 UTC
Created attachment 131652 [details]
Screenshot 1
Comment 4 tomzi 2013-02-21 08:26:04 UTC
Created attachment 131653 [details]
Screenshot 2
Comment 5 tomzi 2013-02-21 08:26:09 UTC
Created attachment 131654 [details]
Screenshot 3
Comment 6 tomzi 2013-02-21 08:26:35 UTC
You are just to fast with answering :)

> What screenshot?
> Anyway, the result should be correct. Project node is a logical node that includes its source groups (src, tests, external libraries etc.) and *not* the project folder. So the results may be different because both the times you're trying to look for changes of different folders.
Comment 7 tomzi 2013-02-21 08:29:12 UTC
Screenshot 1 + 3 show that the path of the maven eircom project in 'Projects' and the folder 'jtf' in 'Favorites' are actually the same. Screenshot 2 + 3 show though that the 'Show Changes' action shows different results. Screenshot 3 is correct. I checked with an external commandline client.

I tried 'Cleanup working copy', close/open Netbeans, close/open the eircom project but it didn't make any difference
Comment 8 Ondrej Vrabec 2013-02-21 08:29:39 UTC
Exactly what i'm talking about. It's a logical node and does not contain maven submodules. Discussed in bug #159543

*** This bug has been marked as a duplicate of bug 159543 ***
Comment 9 Ondrej Vrabec 2013-02-21 08:33:56 UTC
To bypass the logic of parent and sub projects you're either supposed to go to Favorites or simply select all the projects you want to commit (parent and all its subprojects).
Comment 10 tomzi 2013-02-21 08:45:07 UTC
OK - that is a totally NOT obvious behaviour, since everybody working with svn 'knows' that if I do a 'Show Changes' on a parent node, I *will* get all changes of the levels below. The current behaviour does not really make sense for SVN. 

If the project would exist of some modules that are part of the current folder hierarchy and some modules that are not in the same folder hierarchy and would perform an SVN action I would only expect the ones IN the current folder hierarchy be part of the SVN 'update/commit', since this is what SVN does....


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo