Bug 226259 - Go to file not showing "Searching..." initially
Go to file not showing "Searching..." initially
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Jump To
7.4
PC Windows 8 x64
: P3 (vote)
: 7.4
Assigned To: Svata Dedic
issues@utilities
:
: 226717 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-18 09:12 UTC by akobberup
Modified: 2013-06-05 09:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description akobberup 2013-02-18 09:12:17 UTC
When opening "Go to file" dialog, (shift + alt + o) and entering some text, the results list is blank, when it should indicate that the search is underway.

If some text is entered quickly after the window is opened, the results list is displaying <No files found>.

When a backspace is entered, a search is started and the text is changed to "<searching...>"
Comment 1 Michel Graciano 2013-02-26 18:01:46 UTC
*** Bug 226717 has been marked as a duplicate of this bug. ***
Comment 2 Svata Dedic 2013-06-04 09:39:11 UTC
Fixed in http://hg.netbeans.org/jet-main/rev/70434b4765af
Comment 3 Quality Engineering 2013-06-05 09:34:36 UTC
Integrated into 'main-golden', will be available in build *201306050626* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/70434b4765af
User: Svata Dedic <sdedic@netbeans.org>
Log: #226259: fixed race between invokeLater update after removeUpdate and concurrent insertUpdate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo