Bug 226192 - Maximized window size wrong after screen resolution change
Maximized window size wrong after screen resolution change
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.2.1
PC Mac OS X
: P3 with 2 votes (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
jdk_bug_8019269
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-15 17:16 UTC by ebakke
Modified: 2013-08-07 09:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ebakke 2013-02-15 17:16:43 UTC
This bug occurs with the NetBeans IDE 7.2.1 on MacOS with Java 1.7. To reproduce:
1) Close NetBeans if open.
2) From the "Displays" MacOS dialog, set the screen resolution to some lower resolution than the maximum/preferred one.
3) Start NetBeans and maximize its window (green traffic light button on top left-hand corner of the window).
4) Now set the screen resolution back to its maximum. The NetBeans window remains the same size, and cannot be made larger (by dragging nor by pressing the maximize button again). The only workaround I have found is to restart the IDE.

jEdit, another Swing app, does not seem to suffer from this problem. I was, however, able to observe the same behavior in a test Swing app I made, so it's probably related to a JDK issue.

Version details:
Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Java: 1.7.0_13; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
System: Mac OS X version 10.8.2 running on x86_64; US-ASCII; en_US (nb)
Comment 1 Antonin Nebuzelsky 2013-06-27 14:11:52 UTC
A new JDK bug filed. It will appear at
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8019269

Closing wontfix on NetBeans side.
Comment 2 Antonin Nebuzelsky 2013-06-27 14:58:20 UTC
ebakke, can you please test with jdk 8 and with jdk 7u40, and report back if the problem is also reproducible?

https://jdk8.java.net/download.html
https://jdk7.java.net/download.html

Thanks.
Comment 3 twolf2919 2013-08-06 17:04:17 UTC
I'm on Mac OS X and my work laptop is also my personal machine.  When at work, I'm hooked up to an external 1920x1200 Dell monitor, while at home I'm connected to a 2560x1440 Cinema Display.  I run NB "full-screen".  When I disconnect at work and reconnect at home, NB doesn't take up the whole screen on the external monitor.  When I click on the "full-size" button, it expands in the horizontal direction to 2560, but doesn't do anything in the vertical direction.  In order for me to get NB to resize completely, I have to restart the IDE :-(
Comment 4 ebakke 2013-08-07 00:53:14 UTC
Wops, I forgot to respond to the previous comment. Will try on the newest JDK once I have a secondary monitor around again.
Comment 5 ebakke 2013-08-07 05:55:33 UTC
I was able to reproduce the bug again today, then upgraded to 7u40 (Java: 1.7.0_40-ea; Java HotSpot(TM) 64-Bit Server VM 24.0-b55), and the bug seems to have disappeared. I will keep using 7u40 for a while and see if the bug resurfaces (especially in a multimonitor setting, which I don't currently have access to). Thanks for your help!

-- Eirik
Comment 6 Antonin Nebuzelsky 2013-08-07 09:08:07 UTC
(In reply to comment #5)
> upgraded to 7u40 and the bug seems to have disappeared.
> I will keep using 7u40 for a while and see if the bug resurfaces.

Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo