Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 226145 - Code Fold Memory
Code Fold Memory
Status: RESOLVED DUPLICATE of bug 188573
Product: editor
Classification: Unclassified
Component: Code folding
7.3
PC Linux
: P3 (vote)
: TBD
Assigned To: Svata Dedic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-15 05:43 UTC by wnjordan
Modified: 2013-02-19 21:01 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
IDE log (36.09 KB, text/plain)
2013-02-15 05:43 UTC, wnjordan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wnjordan 2013-02-15 05:43:18 UTC
Product Version = NetBeans IDE 7.3 RC2 (Build 201302050851)
Operating System = Linux version 3.2.0-37-generic running on amd64
Java; VM; Vendor = 1.7.0_13
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01

When working on a scripts we often set the code folds exactly the way that we need them, only to close the file and lose the folds.  A very useful, time saving, feature would be if the IDE automatically saved the folds and refolded the script exactly as it was the next time it's opened.
Comment 1 wnjordan 2013-02-15 05:43:21 UTC
Created attachment 131410 [details]
IDE log
Comment 2 Svata Dedic 2013-02-19 21:00:43 UTC
I am slowly progressing towards that one. However it will require nontrivial implementation. Consider a large HTML file, "collapse all" action ... and then persist the state. Ouch.

Currently I am trying to prevent individual module owners from providing initial fold state themselves (infrastructure should do that).

*** This bug has been marked as a duplicate of bug 41232 ***
Comment 3 Svata Dedic 2013-02-19 21:01:31 UTC
(sorry; found even earlier request)

*** This bug has been marked as a duplicate of bug 188573 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo