Bug 226135 - uninstallation fails. complaint that something was not found in the registry.
uninstallation fails. complaint that something was not found in the registry.
Status: RESOLVED INVALID
Product: installer
Classification: Unclassified
Component: NBI
7.3
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Jiri Rechtacek
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-14 17:21 UTC by pbelbin
Modified: 2013-02-15 16:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
install log file as requested (4.13 MB, application/octet-stream)
2013-02-14 19:06 UTC, pbelbin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pbelbin 2013-02-14 17:21:18 UTC
upon invoking the uninstallation of NetBeans 7.3 fcs sanity check, I am greeted with a dialog box that says:

title: Missing target component
text: The specified target component - nb-base/7.3.0.0.201302062200 was not found in the registry.  The installer can continue as if the target component was not speficied.  Click Yes to continue, No to exit the installer.

clicking 'yes', and then clicking 'uninstall' on the next prompt, it very quickly moves to showing 'finish' as the only available button.

however, the NetBeans IDE 7.3 desktop icon is still present, and the app is still listed as being able to be uninstalled from the Programs and Features list.

NetBeans was not running at the time.

so it seems I have been unsuccessful in removing.

I am running Windows 7 x64 with JDK 1.7 update 13.
Comment 1 pbelbin 2013-02-14 17:30:02 UTC
I should mention that during installation, I did specify the --userdir option so that the installation would not see the other already installed (previously) glassfish instances.

perhaps that has something to do with the problem?

not sure.
Comment 2 Jiri Rechtacek 2013-02-14 18:43:49 UTC
Not reproducible on linux - netbeans-7.3-linux.sh.
Comment 3 Jiri Rechtacek 2013-02-14 18:50:23 UTC
(In reply to comment #1)
> I should mention that during installation, I did specify the --userdir option
> so that the installation would not see the other already installed (previously)
> glassfish instances.
Where? NetBeans installer doesn't have '--userdir' option I think. What do you see if you invoke netbeans-7.3-windows.exe --help on Windows command prompt?

> perhaps that has something to do with the problem?
Please, attach installation/uninstallation logs from C:\Users\<your-account>\.nbi\log (attach the two latest ones). It can help to investigate any possible problem. Thank you

> not sure.
Comment 4 pbelbin 2013-02-14 19:06:52 UTC
Created attachment 131401 [details]
install log file as requested

log file as requested.

note, this log file is from the installation of the latest fcs proposal builds, and it was installed using a slightly different --userdir location.

regards,
peter
Comment 5 pbelbin 2013-02-14 19:08:07 UTC
I have provided the log file as requested.

note that the list of installer options I used is that which is available here:

http://wiki.netbeans.org/NBICommandLineOptions

which clearly lists the --userdir option.

regards,
peter
Comment 6 Libor Fischmeistr 2013-02-15 07:35:39 UTC
I suppose you should specify --userdir while uninstall as well, because otherwise unistaller cannot find the right .nbi folder.
Comment 7 Libor Fischmeistr 2013-02-15 07:41:47 UTC
(In reply to comment #6)
> I suppose you should specify --userdir while uninstall as well, because
> otherwise unistaller cannot find the right .nbi folder.

Oh, sorry, now from the log I see you've done it. Am I right?
Comment 8 Libor Fischmeistr 2013-02-15 07:48:06 UTC
I tried to reproduce but was unsuccessful. The uninstallation with custom userdir passed.
Comment 9 Jiri Rechtacek 2013-02-15 09:30:40 UTC
(In reply to comment #4)
> Created attachment 131401 [details]
> install log file as requested
> 
> log file as requested.
> 
> note, this log file is from the installation of the latest fcs proposal builds,
> and it was installed using a slightly different --userdir location.
> 
> regards,
> peter

Thanks. But we need the uninstallation log (it means the latest one) too.
Comment 10 Jiri Rechtacek 2013-02-15 09:33:03 UTC
(In reply to comment #5)
> I have provided the log file as requested.
> 
> note that the list of installer options I used is that which is available here:
> 
> http://wiki.netbeans.org/NBICommandLineOptions
> 
> which clearly lists the --userdir option.
Oops, it's just a option documented on Web only for developers with NBI engine, but the common IDE users. I don't see why it's tracked as P1 then.

> 
> regards,
> peter
Comment 11 pbelbin 2013-02-15 15:55:27 UTC
hold on there.

just because you have been unable to reproduce it does not mean the issue can be swept under the rug.

the value of the --userdir is this:

it's the only way I know of to allow a full install of content from the installation package, without the installer seeing that another instance of glassfish is installed already.

I may be a bit paranoid or overly cautious about this aspect, but, I understand that when it comes to glassfish, that when netbeans installs it (or, perhaps rather, creates a domain) that there are some customizations that are done to glassfish over and above what you would get if you stick with the glassfish.zip directly obtainable from the glassfish download site.

Also, the customizations may change from one version of netbeans to another.

so, I really don't want my glassfish instances getting mixed up due to having two or more versions of NetBeans knowing about/messing with the one instance of glassfish installation.

the netbeans installer, if run without any options, detects that glassfish is there, and *will not allow* the user to install another instance of it.

now.  the fact that you've been able to install and uninstall is great.

but, you have not shared what value you used for your --userdir command option for me to be able to test with to see if I can reproduce your success.

please do, and I'll give it a try.

until then, as far as I'm concerned, this is still broken.

and, as you should be aware, when you go into the windows add/remove programs tooling, you do not have the option of specifying any command line options.

the installer should be (and seeming is) capturing what the --userdir option at installation was, and re-using that information during the uninstall.

I am certainly not specifying it when I try to uninstall.  there is no way to do so.

unless you're referring to manually running the uninstaller app and giving there the --userdir option?

and, are you testing with Windows 7 x64?

I don't know, but that may make a difference.

best regards,
peter
Comment 12 Libor Fischmeistr 2013-02-15 16:07:42 UTC
(In reply to comment #11)
> I am certainly not specifying it when I try to uninstall.  there is no way to
> do so.
> 
> unless you're referring to manually running the uninstaller app and giving
> there the --userdir option?

In this case there is nothing to solve. If you run the installer with the userdir specified, you also have to run the unistaller with the same userdir parameter to let the uninstaller find all necessary files to pass the unistallation.

It's the same like when you run the installer:

unistaller.exe --userdir <nbi folder>

And you have to do it manually from the command line...

Try it and you will see, that everything is ok.

Thanks
Comment 13 pbelbin 2013-02-15 16:32:12 UTC
Ok.  

thank you for clarifying.

I tried the manual uninstall.exe --userdir ${path-given-at-install}

and yay!  it does work.

I don't recall ever having to run the uninstall manually in the past to achieve the desired uninstallation, but at least this is workable.

ie: I think there's still something broken here, but, I agree it is not a show stopper any longer.


all the best,
peter


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo