Bug 226132 - TreeView.paint blocked by 27s in java.io.UnixFileSystem.list[native]()
TreeView.paint blocked by 27s in java.io.UnixFileSystem.list[native]()
Status: RESOLVED DUPLICATE of bug 239779
Product: platform
Classification: Unclassified
Component: Explorer
7.3
All All
: P2 (vote)
: TBD
Assigned To: Jan Peska
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 226300 227090 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-14 15:50 UTC by Alexander Simon
Modified: 2014-03-05 12:07 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (1.30 MB, application/nps)
2013-02-14 15:50 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2013-02-14 15:50:26 UTC
This issue was reported manually by alexvsimon.
It already has 10 duplicates 


Build: NetBeans IDE 7.3 RC2 (Build 201302050851)
VM: Java HotSpot(TM) Client VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_13-b20
OS: SunOS

User Comments:
GUEST: Happens while switching to another project group.
The whole process of switching the group tooked more than 5 minutes, inclusive background scanning.

sreimers: Switching to files view

alexvsimon: Save file

GUEST: Trying to open remotly opened project by expanding the tree



Maximum slowness yet reported was 215648 ms, average is 57491
Comment 1 Alexander Simon 2013-02-14 15:50:41 UTC
Created attachment 131397 [details]
nps snapshot
Comment 2 Petr Cyhelsky 2013-02-14 17:47:30 UTC
Reassigning to platform/nodes - Jardo can you please evaluate what is going on in the deadlock detector?
Comment 3 Petr Cyhelsky 2013-02-19 12:39:20 UTC
*** Bug 226300 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2013-02-26 09:01:47 UTC
As usual in Alex's case: running on extremely slow file system.
Comment 5 Petr Cyhelsky 2013-03-07 08:50:44 UTC
*** Bug 227090 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Simon 2014-03-05 11:59:50 UTC
P2 because 34 reports
Comment 7 Ondrej Vrabec 2014-03-05 12:07:50 UTC

*** This bug has been marked as a duplicate of bug 239779 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo