Bug 226128 - javax.persistence.Persistence
javax.persistence.Persistence
Status: NEW
Product: java
Classification: Unclassified
Component: Compiler
7.2.1
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-14 15:26 UTC by rdg_software
Modified: 2013-02-19 19:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (823.10 KB, text/plain)
2013-02-14 15:27 UTC, rdg_software
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rdg_software 2013-02-14 15:26:45 UTC
Product Version = NetBeans IDE 7.2.1 (Build 201210100934)
Operating System = Mac OS X version 10.6.8 running on x86_64
Java; VM; Vendor = 1.6.0_37
Runtime = Java HotSpot(TM) 64-Bit Server VM 20.12-b01-434

java.lang.ClassNotFoundException: Will not load class javax.persistence.Persistence arbitrarily from one of ModuleCL@cc749e4[javax.persistence] and ModuleCL@1b0fb9bd[org.netbeans.modules.hibernatelib] starting from ModuleCL@1db5d2b2[it.rdg_software.scuola.api.implement]; see http://wiki.netbeans.org/DevFaqModuleCCE
	at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:244)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Comment 1 rdg_software 2013-02-14 15:27:09 UTC
Created attachment 131394 [details]
IDE log
Comment 2 rdg_software 2013-02-15 14:15:07 UTC
Same problem with the CRUD Customer Application if built on scratch fro the Netbeans Tutorial.
It seems impossible to view the persistence.xml.
The problem has born in the moment I did Clean and Build over the Netbeans Platform Application.
Before I was making changes on single modules and the Persistence Library did not any problem.
Everything seemed to function very well until tah moment of Clean and Build over the Netbeans Platform Application.
This was the reason I tried to built from the tutorial but after buiding the viewer component I got the same problem.
Thanks.
Comment 3 rdg_software 2013-02-16 19:30:27 UTC
Also changed the database driver PostgreSQL with the version useful in the Services tab to make the connection.
but with no result. The topcomponent can't be instantiated because the EntityManager do not find
the persistence library unit, it seems. I repeated the tutorial http://platform.netbeans.org/tutorials/nbm-crud.html#creating-entity


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo