Bug 226062 - IDE does not allow to adjust compile command of unmanaged project
IDE does not allow to adjust compile command of unmanaged project
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.3
All All
: P3 (vote)
: 7.3.1
Assigned To: Alexander Simon
issues@cnd
73patch2-verified cnd-clone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-13 14:12 UTC by Alexander Simon
Modified: 2013-05-14 10:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2013-02-13 14:12:11 UTC
Steps to reproduce:
- open project with existing sources
- open compilation unit in editor
- press F9
IDE compiles the file. It is great.
But I do not understand which command IDE uses to compile the file.
As I understand some times IDE:
- invokes compiler with -I and -D defined in the file properties and does not produce object file (it results in compiler error because some of the source code are compiled only with additional flags).
- invoke compiler with all flags as make was built the file and produces object file (some times I do not want to rewrite object files because I check only compiler errors)
So IDE should allow adjust compile command.
Comment 1 Alexander Simon 2013-02-14 13:12:51 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/1c652aabf137
Comment 2 Quality Engineering 2013-02-20 05:26:54 UTC
Integrated into 'main-golden', will be available in build *201302192300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1c652aabf137
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #226062 IDE does not allow to adjust compile command of unmanaged project
Comment 3 Alexander Simon 2013-02-20 08:21:32 UTC
Feature is needed to be tested and documented
Comment 4 Alexander Simon 2013-04-02 10:20:00 UTC
Note: pre required fixex from bug #226059
Comment 5 Alexander Simon 2013-04-02 15:04:24 UTC
additional fix of explanation:
http://hg.netbeans.org/cnd-main/rev/b3d72daf402e
Comment 6 Alexander Pepin 2013-04-04 15:11:36 UTC
verified in dev solstudio build
Comment 7 soldatov 2013-05-14 10:07:48 UTC
Verified in NetBeans 7.3 patch 2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo