Bug 226005 - NullPointerException at com.sun.tools.javac.jvm.Code.emitop1w
NullPointerException at com.sun.tools.javac.jvm.Code.emitop1w
Status: RESOLVED DUPLICATE of bug 178299
Product: java
Classification: Unclassified
Component: Compiler
All All
: P3 (vote)
: 8.1
Assigned To: Dusan Balek
: 187641 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2013-02-12 07:14 UTC by Milos Kleint
Modified: 2014-08-04 15:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT

stacktrace (4.97 KB, text/plain)
2013-02-12 07:14 UTC, Milos Kleint
stacktrace (4.90 KB, text/plain)
2014-04-04 09:58 UTC, Alexander Simon

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Kleint 2013-02-12 07:14:22 UTC
Build: NetBeans IDE Dev (Build 201301240001)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-b18
OS: Windows 7

User Comments:
GUEST: Resolving conflicts of a Java source code

   at com.sun.tools.javac.jvm.Code.emitop1w(Code.java:939)
   at com.sun.tools.javac.jvm.Items$LocalItem.load(Items.java:392)
   at com.sun.tools.javac.jvm.Gen.visitBinary(Gen.java:1959)
   at com.sun.tools.javac.tree.JCTree$JCBinary.accept(JCTree.java:1568)
   at com.sun.tools.javac.jvm.Gen.genExpr(Gen.java:840)
   at com.sun.tools.javac.jvm.Gen.genCond(Gen.java:820)
Comment 1 Milos Kleint 2013-02-12 07:14:24 UTC
Created attachment 131273 [details]
Comment 2 Alexander Simon 2014-04-04 09:58:26 UTC
Created attachment 146541 [details]

build project in console
Comment 3 Svata Dedic 2014-07-31 10:49:51 UTC
No report except the last one (#719925) are relevant to 8.0 release.  Possibly #657465 might be related. 

Both #657465 and #719925 show an error fired up from an annotation processor during enter phase and subsequent compiler failure.

The cause might be a missing symbol (because of unfinished compilation phase), or an invalid local index (= a compiler implementation error). The VarSymbol.adr is written by newLocal in code generator, but also by Flow definitive assignment analyzer. If a symbol's use in code generator would be used before its VarDef is visited, AND it's index from the definitive assignment analysis is high enough - this error could happen.
I'm not sure whether/how this can happen though.
Comment 4 Svata Dedic 2014-07-31 10:52:09 UTC
*** Bug 187641 has been marked as a duplicate of this bug. ***
Comment 5 Svata Dedic 2014-08-04 15:17:10 UTC

*** This bug has been marked as a duplicate of bug 178299 ***

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo