Bug 225935 - Regression in Color Contrast in Find & Replace Panel
Regression in Color Contrast in Find & Replace Panel
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Search
7.3
PC Linux
: P3 (vote)
: 7.3.1
Assigned To: Milutin Kristofic
issues@editor
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-09 14:34 UTC by mjr_1974
Modified: 2013-05-10 16:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
How it looked in 7.3 Beta 2 (12.54 KB, image/png)
2013-02-09 14:35 UTC, mjr_1974
Details
How it looks in 7.3 RC1 (15.37 KB, image/png)
2013-02-09 14:35 UTC, mjr_1974
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mjr_1974 2013-02-09 14:34:27 UTC
Product Version = NetBeans IDE 7.3 RC1 (Build 201301240957)
Operating System = Linux version 3.7.5-030705-generic running on amd64
Java; VM; Vendor = 1.7.0_13
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01

There might be a hard coded color somewhere that makes it very hard to read the find and replace text entered in the text boxes when using a dark theme in the desktop. 
It used to be fine in the previous versions (Beta2) but not anymore. See pictures for comparison.
Comment 1 mjr_1974 2013-02-09 14:35:30 UTC
Created attachment 131192 [details]
How it looked in 7.3 Beta 2
Comment 2 mjr_1974 2013-02-09 14:35:58 UTC
Created attachment 131193 [details]
How it looks in 7.3 RC1
Comment 3 Milutin Kristofic 2013-02-11 13:07:55 UTC
Fixed in dev build
http://hg.netbeans.org/jet-main/rev/dbf6e9e7527b
Comment 4 Quality Engineering 2013-02-12 01:40:54 UTC
Integrated into 'main-golden', will be available in build *201302112300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dbf6e9e7527b
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #225935 - Regression in Color Contrast in Find & Replace Panel
Comment 5 Quality Engineering 2013-02-21 04:02:16 UTC
Integrated into 'main-golden', will be available in build *201302202300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/fac4a94bcf2e
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #225935 - Regression in Color Contrast in Find & Replace Panel - gtkfix
Comment 6 mjr_1974 2013-02-25 23:56:50 UTC
The problem still persists in NB 7.3... should I reopen this bug? Or the fix will be available in a later build?
Comment 7 Milutin Kristofic 2013-02-26 09:41:37 UTC
Fix will be in later build. I set it as 73patch-candidate
Comment 8 Martin Kanak 2013-03-05 12:47:45 UTC
I want to verify this issue but I need to know which dark theme you used. I try it with Dark Nimbus Theme and it is OK, but the theme on screenshots in attachments seems different.
Comment 9 mjr_1974 2013-03-05 14:22:56 UTC
I am running linux mint with a desktop theme: Boje (and this is not the only theme in which the problem shows up). Should I download the current devel build to test it? I can upload pictures after that.
Comment 10 Marian Mirilovic 2013-03-07 07:36:23 UTC
(In reply to comment #9)
> I am running linux mint with a desktop theme: Boje (and this is not the only
> theme in which the problem shows up). Should I download the current devel build
> to test it? I can upload pictures after that.

Please please, do so : http://bits.netbeans.org/download/trunk/nightly/latest/ and let us know, so we can backport the fix into NB 7.3 Patch 1. 
Thanks in advance !
Comment 11 mjr_1974 2013-03-07 15:48:32 UTC
The problem is still there... Also, when I installed the dev version it did not offer to import settings from my current install (so I have no subversion, the code color scheme is gone, and so on...). Anyway, back to the problem, I am sure there has been code updates that made this bug. Otherwise, how one would explain that 7.3 Beta 2 works fine while *all* the releases after that have the problem...
Comment 12 Milutin Kristofic 2013-03-07 15:51:27 UTC
What is your look and feel?
Comment 13 Milutin Kristofic 2013-03-07 16:36:15 UTC
Ok, I checked Boje theme with GTK and I have it also white, since UIManager.get("EditorPane.background") is white under Boje. I would recommend Dark Metal or Dark Nimbus in Netbeans-Options-Miscellaneous-Windows-Look and Feel.
Comment 14 mjr_1974 2013-03-07 18:01:39 UTC
Wouldn't it be better to get the colors from the text editor? In that case, the custom colors that one define (which one can assume will provide good contrast) will ensure right visibility there too...
Comment 15 Milutin Kristofic 2013-03-11 16:25:54 UTC
Ok, This should work on normal theme and boje theme. I tested it on ubuntu 12.04. 

http://hg.netbeans.org/jet-main/rev/a8b247b2f9f7
Comment 16 Quality Engineering 2013-03-13 02:10:12 UTC
Integrated into 'main-golden', will be available in build *201303122300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a8b247b2f9f7
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #225935 - Regression in Color Contrast in Find & Replace Panel
Comment 17 Milutin Kristofic 2013-03-13 10:54:10 UTC
This needs more testing on different Look and feels and themes. Set to patch2
Comment 18 Jiri Prox 2013-03-13 15:43:01 UTC
verified that it's ok with Boje theme, I'll try another dark themes
Comment 19 Jiri Prox 2013-05-02 09:37:19 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo