Bug 225931 - RTL Language handling is so bad
RTL Language handling is so bad
Status: RESOLVED INCOMPLETE
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.4
PC Windows 8
: P1 (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-09 10:26 UTC by muslimmeskeen
Modified: 2013-02-11 16:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
already installed netbeans 7.3 (12.51 KB, image/png)
2013-02-10 09:05 UTC, muslimmeskeen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muslimmeskeen 2013-02-09 10:26:10 UTC
Product Version = NetBeans IDE 6.9.1 (Build 201007282301)
Operating System = Windows NT (unknown) version 6.2 running on x86
Java; VM; Vendor = 1.6.0_22
Runtime = Java HotSpot(TM) Client VM 17.1-b03

Thank u guys for good working and improving netbeans..
unfortunatly.. I cann't get benefits of newer versions improvments, because all my websites oriented for arab clients.. which means that i need an editor with good support for Arabic Language..
Till Netbeans v.6.9 manipulating Arabic characters & sentences is a bit noisy.. but since v7.0 it turned to be trully difficult, nearly impossible to manipulate (adding, editting, selecting, deleteing) arabic words, chracters or sentences inside html tags, css comments or programming language editor..
Pleassssssssssssse try to fix this issue as soon as possible..
Kindly notify me when there is something about it..

mail: aa.m.allinone@gmail.com

Thank u guys..
Comment 1 muslimmeskeen 2013-02-09 10:26:36 UTC
Thank u guys for good working and improving netbeans..
unfortunatly.. I cann't get benefits of newer versions improvments, because all my websites oriented for arab clients.. which means that i need an editor with good support for Arabic Language..
Till Netbeans v.6.9 manipulating Arabic characters & sentences is a bit noisy.. but since v7.0 it turned to be trully difficult, nearly impossible to manipulate (adding, editting, selecting, deleteing) arabic words, chracters or sentences inside html tags, css comments or programming language editor..
Pleassssssssssssse try to fix this issue as soon as possible..
Kindly notify me when there is something about it..

mail: aa.m.allinone@gmail.com

Thank u guys..
Comment 2 Marian Mirilovic 2013-02-10 06:58:10 UTC
Please, could you be more specific? Write down exact steps to reproduce please.

Also, could you try the latest NB 7.3, that is above to be released in couple days ?
Comment 3 muslimmeskeen 2013-02-10 09:05:42 UTC
Created attachment 131204 [details]
already installed netbeans 7.3
Comment 4 muslimmeskeen 2013-02-10 09:06:28 UTC
I'm already talking about 7.3.. tried it before posting this..
see attachment
the problem exactly is:
You can't select Arabic words in an Html page..
when you point to it with mouse then dbl click or drag to select, there is something wrong happens, so it selects another word in the sentence.

So that you can't edit, add or delete some words or characters correctly in the Arabic sentences..

also this problem in all file types.
Comment 5 Miloslav Metelka 2013-02-10 10:28:53 UTC
Recently I've fixed issue #65158 in Dev builds. Could you download a Dev build and try the things there if you see any difference against 7.3 behavior? Thanks.
Comment 6 muslimmeskeen 2013-02-10 11:37:30 UTC
where is the link???? please refer
Comment 7 Miloslav Metelka 2013-02-11 16:41:34 UTC
http://bits.netbeans.org/download/trunk/nightly/latest/


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo