Bug 225896 - Can not scroll to "other" in "new file" dialog
Can not scroll to "other" in "new file" dialog
Status: RESOLVED DUPLICATE of bug 219709
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.3
PC Linux
: P1 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 13:57 UTC by everflux
Modified: 2013-02-13 07:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
showing the last row accessible (61.45 KB, image/png)
2013-02-08 14:06 UTC, everflux
Details
Note how a larger dialog still displays the scroll bar but showing the last row ("Other") which is not accessible in the smaller dialog (69.71 KB, image/png)
2013-02-08 14:12 UTC, everflux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description everflux 2013-02-08 13:57:48 UTC
[ BUILD # : 201302062200 ]
[ JDK VERSION : 1.7.0_09 ]

I have just installed the latest Netbeans 7.3 (FCS acceptance build, "full"
version)
Using a maven java-ee project I wanted to add a new file.

Rightlick on folder, new -> "other..." brought up the new file dialog.
I could not scroll down the categorie to "other" in order to create a plain
file, the scroll list always jumped up.

I think this is a duplicate of
http://netbeans.org/bugzilla/show_bug.cgi?id=219709  which is marked as "won't
fix".

Honestly I think this gives a really really bad impression of the Netbeans IDE,
if a basic feature as creating a new file is so broken that even me as an
experienced user had to read the old bug report for a workaround.
Resizing the dialog mitigates the problem, yes. But this is not intuitive and
there is no hint for the user what he is expected to do.

I file this as P1 because a basic feature is not working properly - if you
change the default dialog size for "new file" for the FCS build the priority
can of course be reduced.
Comment 1 Milutin Kristofic 2013-02-08 14:02:43 UTC
Dialogs are responsibility of platform/dialogs.
Comment 2 everflux 2013-02-08 14:06:50 UTC
Created attachment 131151 [details]
showing the last row accessible
Comment 3 everflux 2013-02-08 14:12:11 UTC
Created attachment 131152 [details]
Note how a larger dialog still displays the scroll bar but showing the last row ("Other") which is not accessible in the smaller dialog
Comment 4 vanob 2013-02-08 15:18:04 UTC
I can reproduce it on my Solaris 11.1, Gnome 2.30.2
Comment 5 Stanislav Aubrecht 2013-02-08 15:29:58 UTC
It's a bug in JDK.
Next time you see this problem just resize the dialog window.

*** This bug has been marked as a duplicate of bug 219709 ***
Comment 6 everflux 2013-02-08 15:35:38 UTC
Perhaps the default size should be increased to mitigate a bad experience until the JDK receives a fix.
Comment 7 Stanislav Aubrecht 2013-02-08 15:37:38 UTC
(In reply to comment #6)
> Perhaps the default size should be increased to mitigate a bad experience until
> the JDK receives a fix.

There's not 'correct' default size. The tree size depends on look and feel, font size, font style, locale etc...
In any case this is hardly a P1 issue.
Comment 8 Marian Mirilovic 2013-02-08 15:45:45 UTC
everflux,
could you please try to use the latest, publicly available JDK (7u13) ? 

BTW: according to the original report, it was already fixed in newer version of JDK
Comment 9 everflux 2013-02-08 15:58:33 UTC
java -version
java version "1.7.0_13"
Java(TM) SE Runtime Environment (build 1.7.0_13-b20)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

I am using it already - the NetCat bugreport form did not provide that version as an option.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo