Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 225747 - Allow more detailed control of whitespace and newline highlighting
Allow more detailed control of whitespace and newline highlighting
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.3
All All
: P2 (vote)
: 7.4
Assigned To: Miloslav Metelka
issues@editor
:
: 205247 205854 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 13:33 UTC by Miloslav Metelka
Modified: 2013-08-01 14:03 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miloslav Metelka 2013-02-05 13:33:38 UTC
There could be an extra Tab "Whitespace" in Tools->Options->Fonts&Colors with a listbox on the left with three items:

Indentation Whitespace
Trailing Whitespace
Newline

On the right there would be a checkbox whether particular highlight is applied or not and a highlight configuration like under "Syntax" tab.
 However I somewhat resist to put this under Syntax tab since it's not related to syntax of the language and it would not be turnable on/off. Highlighting tab does not offer font (or effects) change which could be beneficial here since it would be applied to the font of non-visible chars display.
Comment 1 Miloslav Metelka 2013-05-15 14:31:36 UTC
Current solution are items in Tools->Options->Fonts&Colors->Highlighting tab:

Indentation Whitespace
Trailing Whitespace

When assigning background colors to them the indentation/trailing whitespace will start to be shown.

http://hg.netbeans.org/jet-main/rev/4e035f03b6eb
Comment 2 Quality Engineering 2013-05-18 02:53:13 UTC
Integrated into 'main-golden', will be available in build *201305172300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4e035f03b6eb
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #225747 - Allow more detailed control of whitespace and newline highlighting.
Comment 3 Milutin Kristofic 2013-08-01 14:03:36 UTC
*** Bug 205854 has been marked as a duplicate of this bug. ***
Comment 4 Milutin Kristofic 2013-08-01 14:03:57 UTC
*** Bug 205247 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo