Bug 225745 - Editing and then saving file in local network PHP project doesn't show changes in my IDE
Editing and then saving file in local network PHP project doesn't show change...
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Filesystems
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 12:20 UTC by d4mn
Modified: 2013-07-23 09:48 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description d4mn 2013-02-05 12:20:28 UTC
Our team is working on local network with same project.
Let's say project is in my PC. Other coders from local network opens my project which is in my pc from network. When they do changes to project files I don't see changes in my netbeans window. On the other hand when they do changes with some other editor (Adobe dreamveawer, notepad++) i can see changes in files immediately. We've tried versions 7.3 Beta 2, 7.3 RC1, also dev versions 201302020001, 201302040001. If i remember in version 7.2 there were no such BUG.

I don't know what attachment should I attach so please tell me if you need one. And also would be great to know if anyone else has encountered this problem. It makes me sick when I have to reopen tab or file itself after external changes to save it correctly.

P.S Forgot to mention my project is configured for remote connection that's mean all file saves are uploaded to server. But this works when my colleagues are using other editors then Netbeans.
Comment 1 Petr Jiricka 2013-02-06 09:05:34 UTC
Thanks for the report, though this does not sounds like a P1 problem, changing to P2. Assigning to filesystems for evaluation.
Comment 2 Jaroslav Tulach 2013-02-06 11:44:17 UTC
What do you mean by "netbeans window"? Projects tab?

You can run your IDE with
-J-Dorg.netbeans.modules.masterfs.watcher.level=FINE
option to verify that the external changes are not observed by the IDE. Attach the log file.

Btw. I think there is an easy workaround: Tools/Options/Misc/Files and disable "autoscanning for sources". Then you can right click on a folder and use "refresh folder" action.
Comment 3 d4mn 2013-02-11 11:20:15 UTC
Hi,

I tried running IDE with -J-Dorg.netbeans.modules.masterfs.watcher.level=FINE but it doesn't work I don't see changes in in opened file when it was changed. I think the problem is how netbeans saves a file when it is changed. Because when a file is edited with some other software and saved netbeans sees that it was changed and updates it. 

I don't want to turn off autoscanning because this is exactly what i want.

I'll try to explain by an example.

Let's say I and my colleague are working on a same project. I'm editing index.php and my colleague is editing main.css. When my colleague saves a file I have to go to main.css file tab and then netbeans sees changes and saves it to remote server. If I don't open file main.css it can be never saved to remote server. And all edited content can be lost. When my colleague is working with other Editor I don't have to open main.css file to save changes to server netbeans sees the changes automatically and saves file to remote server. So i think the problem is how netbeans saves a file.
Comment 4 Jaroslav Tulach 2013-07-23 09:31:35 UTC
You need to run with -J-Dorg.netbeans.modules.masterfs.watcher.level=FINE and attach IDE's log file, so we can compare what the IDE does on background with respect to actions you do.

Also I am not sure if this is not some PHP related problem, so CCing Tomáš.
Comment 5 Tomas Mysik 2013-07-23 09:48:35 UTC
(In reply to comment #4)
> Also I am not sure if this is not some PHP related problem, so CCing Tomáš.

I don't think so.

(In reply to comment #0)
> Our team is working on local network with same project.

Very bad idea, you can easily overwrite changes done by someone else. Using any SCM is the proper way to go...

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo