Bug 225720 - NullPointerException at com.sun.java.swing.plaf.windows.WindowsTreeUI.ensureRowsAreVisible
NullPointerException at com.sun.java.swing.plaf.windows.WindowsTreeUI.ensureR...
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.2
All All
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT
:
: 225435 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 19:44 UTC by Exceptions Reporter
Modified: 2013-07-30 14:44 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.57 KB, text/plain)
2013-02-04 19:44 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-02-04 19:44:40 UTC
This bug was originally marked as duplicate of bug 194929, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2.1 (Build 201210100934)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.0-b09, Java(TM) SE Runtime Environment, 1.6.0_23-b05
OS: Windows 7

User Comments:
GUEST: Deleted a folder, didn't disappear from the Projects list, then tried to expand/collapse the parent folder.

GUEST: Updating files via CVS; an expanded portion of the tree became blank.  The space that should have been taken up by the file display was simply white.  I closed & re-expanded portions of the tree with similar results.  After doing so several times, the error seems to have resolved

rupertkey: [NB6.5Beta1] C/C++ Project: In the Classes panel, expanding the C src file name to show functions gives exception (although the tree shows correct list of functions).

GUEST: Estava tentando excluir uma pasta

twoelectric: Opened a new Kenai project. This may be due to the warning of "source folder" not defined.

GUEST: Updating from CVS.  Everything below web pages in my web app became unclickable

GUEST: deleted the build folder

GUEST: Sorry,

My english is not good!!

When I open package the Netbeans show me this message.

I am not use Swing, my project is JSF2 whith spring.

Bruno Hahn Barreto

jrcampins: deleteing a folder




Stacktrace: 
java.lang.NullPointerException
   at com.sun.java.swing.plaf.windows.WindowsTreeUI.ensureRowsAreVisible(WindowsTreeUI.java:74)
   at javax.swing.plaf.basic.BasicTreeUI.toggleExpandState(BasicTreeUI.java:2208)
   at javax.swing.plaf.basic.BasicTreeUI.handleExpandControlClick(BasicTreeUI.java:2191)
   at javax.swing.plaf.basic.BasicTreeUI.checkForClickInExpandControl(BasicTreeUI.java:2149)
   at javax.swing.plaf.basic.BasicTreeUI$Handler.handleSelection(BasicTreeUI.java:3511)
   at javax.swing.plaf.basic.BasicTreeUI$Handler.mousePressedDND(BasicTreeUI.java:3497)
Comment 1 Exceptions Reporter 2013-02-04 19:44:42 UTC
Created attachment 131013 [details]
stacktrace
Comment 2 Jaroslav Tulach 2013-03-12 15:30:11 UTC
Swing related problem previously identified as JDK problem.
Comment 3 Stanislav Aubrecht 2013-03-13 14:41:32 UTC
All reports are from JDK 1.6, I suggest closing as WONTFIX unless it's reproducible with JDK 1.7
Comment 4 Ondrej Vrabec 2013-06-28 10:52:03 UTC
*** Bug 225435 has been marked as a duplicate of this bug. ***
Comment 5 Stanislav Aubrecht 2013-07-30 14:44:20 UTC
Please reopen if reproducible in JDK 1.7, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo