Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 225685 - JPQL not parsed, no code completion
JPQL not parsed, no code completion
Status: RESOLVED DUPLICATE of bug 212951
Product: javaee
Classification: Unclassified
Component: Persistence
7.3
PC Windows XP
: P3 with 1 vote (vote)
: TBD
Assigned To: Sergey Petrov
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 07:52 UTC by bht
Modified: 2013-02-04 14:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Maven project with example JPQL in entity (7.49 KB, application/octet-stream)
2013-02-04 07:52 UTC, bht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2013-02-04 07:52:32 UTC
Created attachment 130975 [details]
Maven project with example JPQL in entity

It appears that under some conditions JPQL is not parsed and no code completion hints are available.

Please see in the attached example, CustomerOrder.java

The remaining files in the project are not relevant.

Perhaps the condition that is relevant here has other effects, too. I notice that since JPQL parsing was addded, the IDE is much slower but that might be a coincidence.

I would still prefer that JPQL support becomes an optional module.
Comment 1 bht 2013-02-04 07:58:49 UTC

*** This bug has been marked as a duplicate of bug 212951 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo