Bug 225680 - not fixed yet??? wow... very basic problem when window is maximized a certain way
not fixed yet??? wow... very basic problem when window is maximized a certain...
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.3
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
http://bugs.sun.com/bugdatabase/view_...
jdk_bug_9005631
:
: 240542 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 04:35 UTC by mmikeyy
Modified: 2014-01-17 08:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
examples of Netbeans window vertical expansion problem (314.50 KB, image/jpeg)
2013-02-16 05:57 UTC, mmikeyy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mmikeyy 2013-02-04 04:35:04 UTC
Product Version = NetBeans IDE 7.3 RC1 (Build 201301240957)
Operating System = Windows 8 version 6.2 running on x86
Java; VM; Vendor = 1.7.0_13
Runtime = Java HotSpot(TM) Client VM 23.7-b01


Already reported. Not fixed in 5.3RC1... strange...

1) make the netbeans window smaller than screen size, leaving free space all around.
2) with mouse, drag top edge of window to screen top. Hit top and release mouse button the moment it hits.

Expected result: the window should fill the space on the screen, above and below its original position (the sides stay the same).

So as as the top of the window is moved to screen top, the bottom of the window moves to the bottom of the screen. 

PROBLEM: the window behaves as expected (under windows control), BUT Netbeans does not bother filling the adidtional space at the bottom: all extra space at the bottom is now black and empty.

Seems like a super easy problem to fix. Why a major release with such a basic problem still present?
Comment 1 Marian Mirilovic 2013-02-10 08:09:16 UTC
Win 8 specific ?

Tomas, could you reproduce this on our Win8 box ? Thanks in advance.
Comment 2 Stanislav Aubrecht 2013-02-15 15:25:16 UTC
Please attach a screen shot and reopen, thanks.
Also, do you use OpenJDK or Oracle JDK?
Comment 3 mmikeyy 2013-02-16 05:57:15 UTC
Created attachment 131450 [details]
examples of Netbeans window vertical expansion problem

you asked for examples. Here are three examples in one image. Each example shows the original Netbeans window on the left hand side, and the expanded window on the right hand side.

If you need anything else, let me know.

and... no, I'm not using OpenJDK or Oracle JDK
Comment 4 Stanislav Aubrecht 2013-02-17 10:01:57 UTC
(In reply to comment #3)

> and... no, I'm not using OpenJDK or Oracle JDK

Well, what kind JDK are you using then?
Also please attach your IDE log, thanks.
Comment 5 Stanislav Aubrecht 2013-05-21 13:41:04 UTC
The problem is reproducible with a plain JFrame application in Windows 7 with 1.7.0_15; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Comment 6 Stanislav Aubrecht 2013-07-31 12:50:55 UTC
Reported as JDK bug #9005631
Comment 7 Stanislav Aubrecht 2014-01-17 08:57:40 UTC
*** Bug 240542 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo