Bug 225594 - 5s - JavaCompletionProvider$JavaCompletionQuery.resolveDocumentation()
5s - JavaCompletionProvider$JavaCompletionQuery.resolveDocumentation()
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Editor
7.3
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 12:17 UTC by xehpuk
Modified: 2016-07-07 07:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (108.01 KB, application/nps)
2013-01-31 12:17 UTC, xehpuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xehpuk 2013-01-31 12:17:34 UTC
This bug was originally marked as duplicate of bug 209133, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) Client VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_11-b21
OS: Windows 8
Maximum slowness yet reported was 5038 ms, average is 5038
Comment 1 xehpuk 2013-01-31 12:17:37 UTC
Created attachment 130885 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2013-02-04 11:04:48 UTC
Most of the time seems to be spent in 
org.netbeans.modules.editor.java.JavaCompletionProvider$JavaCompletionQuery.resolveDocumentation()	100.0	4,273 ms (100%)	4,273 ms	1
which then does a lot of calls to attribute the tree. For example 53 calls to
com.sun.tools.javac.comp.Attr.attribStat()	19.024666	812 ms (19%)	812 ms	53
Comment 3 Martin Balin 2016-07-07 07:16:08 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo