Bug 225549 - Quotes in php heredoc should not have to be escaped
Quotes in php heredoc should not have to be escaped
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
7.3
All All
: P1 (vote)
: 7.3
Assigned To: Ondrej Brejla
issues@php
: 73_HR_FIX, REGRESSION
: 225557 225832 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 15:30 UTC by berniev
Modified: 2013-02-07 12:39 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description berniev 2013-01-30 15:30:48 UTC
Product Version = NetBeans IDE 7.3 RC1 (Build 201301240957)
Operating System = Linux version 3.0.0-30-generic-pae running on i386
Java; VM; Vendor = 1.6.0_24
Runtime = OpenJDK Client VM 20.0-b12

new to 7.3rc1

<?php
$test = <<<EOT
<a href="{$url}"</a>
EOT;
?>

if double quotes escaped \" then behaves, but escaping is not done as it is supposed to be unnecessary so you can imagine the mess on existing files.
Comment 1 Ondrej Brejla 2013-01-30 15:55:54 UTC
Fixed in web-main #b63892eca879
Comment 2 Ondrej Brejla 2013-01-30 15:59:25 UTC
Regression which breaks coloring of the rest of PHP file. I think that it should be integrated into 7.3 FCS.

CCing mmirilovic and vriha and kanakmar for verification.
Comment 3 Quality Engineering 2013-01-31 03:12:42 UTC
Integrated into 'main-golden', will be available in build *201301310001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b63892eca879
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #225549 - Quotes in php heredoc should not have to be escaped
Comment 4 Ondrej Brejla 2013-01-31 08:36:14 UTC
CCing marfous for review. Thanks.
Comment 5 Ondrej Brejla 2013-01-31 08:49:00 UTC
*** Bug 225557 has been marked as a duplicate of this bug. ***
Comment 6 Martin Fousek 2013-01-31 09:01:10 UTC
(In reply to comment #4)
> CCing marfous for review. Thanks.

The patch looks well to me.
Comment 7 Martin Kanak 2013-01-31 09:17:46 UTC
I can confirm that the patch works fine.

Product Version: NetBeans IDE Dev (Build 201301310001)
Java: 1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-ea-b17
System: Linux version 3.2.0-36-generic running on amd64; UTF-8; en_US (nb)
Comment 8 Ondrej Brejla 2013-01-31 09:20:36 UTC
Thanks for the verification.
Comment 9 Ondrej Brejla 2013-01-31 14:52:12 UTC
Transplanted into releases73 branch - http://hg.netbeans.org/releases/rev/953746a2f010

Testers, please verify, thanks.
Comment 10 Quality Engineering 2013-02-01 01:21:15 UTC
Integrated into 'releases', will be available in build *201301312200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/953746a2f010
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #225549 - Quotes in php heredoc should not have to be escaped
(transplanted from b63892eca879b18c11d4e0f6f16da12710bf5664)
Comment 11 Martin Kanak 2013-02-01 08:34:06 UTC
Verified

Product Version: NetBeans IDE 7.3 RC1 (Build 201301312200)
Java: 1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-ea-b17
System: Linux version 3.2.0-36-generic running on amd64; UTF-8; en_US (nb)
Comment 12 Ondrej Brejla 2013-02-07 12:39:46 UTC
*** Bug 225832 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo