Bug 225537 - NullPointerException at org.netbeans.modules.form.layoutsupport.griddesigner.AnimationLayer.createContainerImage
NullPointerException at org.netbeans.modules.form.layoutsupport.griddesigner....
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: 7.4
Assigned To: issues@guibuilder
issues@guibuilder
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 14:20 UTC by Alexander Simon
Modified: 2013-08-13 17:26 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.74 KB, text/plain)
2013-01-30 14:20 UTC, Alexander Simon
Details
stacktrace (6.02 KB, text/plain)
2013-03-20 06:36 UTC, honza.hubeny
Details
stacktrace (6.02 KB, text/plain)
2013-04-24 18:34 UTC, gholmer
Details
screenshot showing embedded GridBagLayout (25.96 KB, image/png)
2013-04-24 18:40 UTC, gholmer
Details
screenshot showing the component being adjusted (55.65 KB, image/png)
2013-04-24 18:41 UTC, gholmer
Details
stacktrace (1.74 KB, text/plain)
2013-04-25 12:40 UTC, gholmer
Details
stacktrace (6.02 KB, text/plain)
2013-04-25 12:52 UTC, gholmer
Details
stacktrace (6.02 KB, text/plain)
2013-07-18 07:18 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2013-01-30 14:20:32 UTC
This bug was originally marked as duplicate of bug 191206, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 RC1 (Build 20130125-0fbf0f6115da)
VM: Java HotSpot(TM) Client VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_11-b21
OS: SunOS

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.form.layoutsupport.griddesigner.AnimationLayer.createContainerImage(AnimationLayer.java:185)
   at org.netbeans.modules.form.layoutsupport.griddesigner.AnimationLayer.animate(AnimationLayer.java:166)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GlassPane$GridActionWrapper.actionPerformed(GlassPane.java:1499)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GlassPane.performAction(GlassPane.java:1113)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GlassPane.updateLayout(GlassPane.java:227)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GridDesigner$7$1.run(GridDesigner.java:569)
Comment 1 Alexander Simon 2013-01-30 14:20:34 UTC
Created attachment 130836 [details]
stacktrace
Comment 2 Exceptions Reporter 2013-03-15 18:27:24 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=198177
Comment 3 honza.hubeny 2013-03-20 06:36:38 UTC
Created attachment 132814 [details]
stacktrace

changing insets of multiple selected object in the GridBag Customize layout dialog.
Comment 4 gholmer 2013-04-24 18:34:16 UTC
Created attachment 133768 [details]
stacktrace

Changed the insets of a component within an embedded GridBagLayout.
Comment 5 Exceptions Reporter 2013-04-24 18:34:19 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=198177
Comment 6 gholmer 2013-04-24 18:40:31 UTC
Created attachment 133769 [details]
screenshot showing embedded GridBagLayout
Comment 7 gholmer 2013-04-24 18:41:49 UTC
Created attachment 133770 [details]
screenshot showing the component being adjusted

When fourth number in the insets was changed, the error dialog appeared.
Comment 8 gholmer 2013-04-25 12:40:19 UTC
Created attachment 133796 [details]
stacktrace

Removed the border from a JPanel in the GridBagLayout editor.
Comment 9 gholmer 2013-04-25 12:52:18 UTC
Created attachment 133797 [details]
stacktrace

Exception dialog appeared when closing the GridBagLayout editor.
Comment 10 manikantannaren 2013-07-18 07:18:41 UTC
Created attachment 137352 [details]
stacktrace

Created a JFRame
Set layout to GridbagLayout
DnD a number of JLabel and JtextFields
Opened the GridBag customizer
multi-selected the text field by using the mouse (dragging the mouse around the textfields)
Tried to move the selected field to a new cell
Comment 11 Tomas Pavek 2013-08-13 17:26:01 UTC
Looks like the fix of bug 191206 was later accidentally removed.
http://hg.netbeans.org/jet-main/rev/35d007d5cd78


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo