Bug 225526 - Autocompletion fails to provide classes from other Maven module
Autocompletion fails to provide classes from other Maven module
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.3
PC Linux
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 12:06 UTC by mvy
Modified: 2015-09-17 11:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (426.76 KB, text/plain)
2013-01-30 12:06 UTC, mvy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mvy 2013-01-30 12:06:10 UTC
Product Version = NetBeans IDE 7.3 RC1 (Build 201301240957)
Operating System = Linux version 3.5.0-22-generic running on i386
Java; VM; Vendor = 1.7.0_11
Runtime = Java HotSpot(TM) Client VM 23.6-b04

If I add a class to Maven module A, compile the module and then try to use the class in module B (dependent on module A), the class does not show in the Autocompletion hint, no matter how many times I press the ctrl+space combination.
Comment 1 mvy 2013-01-30 12:06:19 UTC
Created attachment 130832 [details]
IDE log
Comment 2 Milos Kleint 2013-01-30 12:25:16 UTC
is the module A's dependency node in module B shown with a project icon? 
Does the module B dependency's version (or GAV in general) match the module A coordinates?
Comment 3 mvy 2013-01-30 12:43:58 UTC
Hello,
> is the module A's dependency node in module B shown with a project icon? 

Yes, the icon in the "Dependencies" section is the two-letter "ma" icon.

> Does the module B dependency's version (or GAV in general) match the module A
coordinates?

Yes, I double-checked it currently. B references to A as follows:

        <dependency>
            <groupId>${project.groupId}</groupId>
            <artifactId>webafis-commons</artifactId>
            <version>${project.version}</version>
        </dependency>
Comment 4 Milos Kleint 2013-02-11 10:08:02 UTC
as per agreement with tzezula reassigning to java/compiler to evaluate the ide log file, most entries coming from java support, specifically 

Coupling error:
class file: file:/home/vyzivus/work/java/webafis-applets/webafis-adjudicator/src/main/java/com/innovatrics/fpunified/FingerprintUnifiedApplet.java
source file: file:/home/vyzivus/work/java/webafis-applets/webafis-adjudicator/src/main/java/com/innovatrics/fpunified/FingerprintUnifiedApplet.java
VARIABLE: <error>
Comment 5 Martin Balin 2015-09-17 11:16:00 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo