Bug 225506 - IllegalArgumentException: failed to parse:application/x-java-openide-nodednd;class=org.openide.nodes.Node;mask=?
IllegalArgumentException: failed to parse:application/x-java-openide-nodednd;...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Nodes
7.3
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 05:05 UTC by Exceptions Reporter
Modified: 2013-11-21 13:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.69 KB, text/plain)
2013-01-30 05:05 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-01-30 05:05:24 UTC
This bug was originally marked as duplicate of bug 187882, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) Client VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows 7

Stacktrace: 
java.lang.IllegalArgumentException: failed to parse:application/x-java-openide-nodednd;class=org.openide.nodes.Node;mask=?
   at java.awt.datatransfer.DataFlavor.<init>(DataFlavor.java:400)
   at org.openide.nodes.NodeTransfer.createDndFlavor(NodeTransfer.java:129)
   at org.openide.nodes.NodeTransfer.transferable(NodeTransfer.java:147)
   at org.openide.nodes.AbstractNode.clipboardCopy(AbstractNode.java:473)
   at org.openide.loaders.DataNode.clipboardCopy(DataNode.java:620)
   at org.openide.loaders.DataFolder$FolderNode.createNodeTransferable(DataFolder.java:1429)
Comment 1 Exceptions Reporter 2013-01-30 05:05:25 UTC
Created attachment 130810 [details]
stacktrace
Comment 2 Jan Peska 2013-08-19 08:21:15 UTC
Jardo, can you please take a look on this since you've added a logging in there for you to have more info.
Comment 3 Jaroslav Tulach 2013-11-21 13:45:33 UTC
Old JDKs, and old NetBeans versions (7.3beta2). Anyway this looks like a problem on a JDK side. There is low probability of making mistake in static initializer that would demonstrate itself randomly.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo