Bug 225473 - 2: No such file
2: No such file
Status: RESOLVED DUPLICATE of bug 216366
Product: cnd
Classification: Unclassified
Component: execution
7.3
All All
: P3 (vote)
: TBD
Assigned To: Maria Tishkova
dlight-issues@cnd
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 13:08 UTC by Exceptions Reporter
Modified: 2013-05-20 08:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.27 KB, text/plain)
2013-01-29 13:08 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-01-29 13:08:30 UTC
This issue was reported manually by alexvsimon.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build nbms-and-javadoc-10157-on-20130124)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-b18
OS: Windows 8

Stacktrace: 
2: No such file
   at com.jcraft.jsch.ChannelSftp.throwStatusError(ChannelSftp.java:2491)
   at com.jcraft.jsch.ChannelSftp.mkdir(ChannelSftp.java:1897)
   at org.netbeans.modules.nativeexecution.api.util.HelperUtility.getPath(HelperUtility.java:181)
   at org.netbeans.modules.nativeexecution.api.util.HelperUtility.getPath(HelperUtility.java:100)
   at org.netbeans.modules.nativeexecution.NbNativeProcess.<init>(NbNativeProcess.java:81)
   at org.netbeans.modules.nativeexecution.NbRemoteNativeProcess.<init>(NbRemoteNativeProcess.java:57)
Comment 1 Exceptions Reporter 2013-01-29 13:08:32 UTC
Created attachment 130780 [details]
stacktrace
Comment 2 Maria Tishkova 2013-05-17 10:02:51 UTC
moved to execution sub-component as dlight is gone from the NetBeans
Comment 3 Maria Tishkova 2013-05-20 08:36:14 UTC
In the messages.log

WARNING [nativeexecution.support.logger]: [67177 ms.] Failed to upload pty
WARNING [nativeexecution.support.logger]: [67177 ms.] File /var/tmp/dlight_u39500769/4afa38b6/01226104776/pty doesnt exist, and cannot be uploaded. Do you have enough privileges?
WARNING [nativeexecution.support.logger]: [67177 ms.] You could try to use -J-Dcnd.tmpbase=<other base location> to re-define default one.


It looks like remote folder /var/tmp/dlight_u39500769/4afa38b6/01226104776 cannot be created, please use additional flag -J-Dcnd.tmpbase=<other base location> 
when running IDE or grant write privileges

*** This bug has been marked as a duplicate of bug 216366 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo