Bug 225467 - navigator has no focus
navigator has no focus
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Navigation
7.3
PC Linux
: P3 (vote)
: 7.4
Assigned To: Milutin Kristofic
issues@editor
: FOCUS
: 226451 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 12:48 UTC by gawan
Modified: 2013-03-19 08:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
navi 1 (77.45 KB, image/png)
2013-02-05 07:32 UTC, gawan
Details
navi 2 (106.74 KB, image/png)
2013-02-05 07:33 UTC, gawan
Details
CslNavigatorPanelUI patch (1.20 KB, patch)
2013-02-06 10:05 UTC, Jan Peska
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gawan 2013-01-29 12:48:30 UTC

    
Comment 1 gawan 2013-01-29 12:50:46 UTC
After press shortcut for show navigator, navigator has no focus. If navigator is docked (pinned) it works correctly. No focus is only if navigator is not always shown.
Comment 2 gawan 2013-01-29 12:52:24 UTC
I am using 7.3 rc1
Comment 3 Ondrej Brejla 2013-01-29 12:54:39 UTC
Navigator is not handled by PHP. We just provide elements, which are displayed there.
Comment 4 Marian Mirilovic 2013-01-29 15:38:47 UTC
JDK ?
Comment 5 gawan 2013-01-29 15:56:38 UTC
I installed ubuntu 12.04 and oracle-java7-installer (Oracle Java(TM) Development Kit (JDK) 7)
Comment 6 Milutin Kristofic 2013-02-04 15:20:59 UTC
Ok. I have ubuntu also. You can copy details from Help->About menu item

My is:
Product Version: NetBeans IDE Dev (Build 201301210001)
Updates: Updates available to version , NetBeans 7.3 Beta 2
Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18

1, I minimized navigator.
2, I opened Java file
3, I pressed Ctrl+2 (shortcut for navigator)
4. I have focus and I can move with keyboard arrow keys.

Do you mean minimized or floating navigator?
Comment 7 gawan 2013-02-05 07:32:09 UTC
Created attachment 131028 [details]
navi 1
Comment 8 gawan 2013-02-05 07:32:58 UTC
Product Version: NetBeans IDE 7.3 RC1 (Build 201301240957)
Java: 1.7.0_11; Java HotSpot(TM) Client VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
System: Linux version 3.2.0-37-generic-pae running on i386; UTF-8; sk_SK (nb)

My Process is same except 4. (I cannot move with arrows keys).

I attached two screenshots:
navi1.png - start position, now I press shortcut for navigator
navi2.png - navigator was shown but arrows keys does not not work (has no focus)
after I click in navigator, then arrows key works
Comment 9 gawan 2013-02-05 07:33:20 UTC
Created attachment 131029 [details]
navi 2
Comment 10 Milutin Kristofic 2013-02-05 15:38:26 UTC
Ok. It cannot be reproduced in java editor, but it is in php editor in nb 7.3. Colleague Honza from platform/navigator will look at it.
Comment 11 Jan Peska 2013-02-06 10:05:50 UTC
Created attachment 131054 [details]
CslNavigatorPanelUI patch

After the Navigator window is activated, statement 

selectedPanel.getComponent().requestFocus()

is called. Unlike the Java Navigation, CslNavigatorPanelUI does not override this (requestFocus) method, so to fix this issue just apply following patch.
Comment 12 Milutin Kristofic 2013-02-06 14:19:27 UTC
Honza, thank you. There is requestFocusInWindow overriden, I thought it was enough. 

http://hg.netbeans.org/jet-main/rev/43771533b7fb
Comment 13 Quality Engineering 2013-02-07 03:07:49 UTC
Integrated into 'main-golden', will be available in build *201302070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dd21192401bd
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #225467 - navigator has no focus
Comment 14 Jan Peska 2013-03-19 08:11:46 UTC
*** Bug 226451 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo