Bug 225392 - message error loading hook: org.eclipse.osgi.internal.baseadaptor.weaving.weavingHookConfigurator
message error loading hook: org.eclipse.osgi.internal.baseadaptor.weaving.wea...
Status: RESOLVED INVALID
Product: platform
Classification: Unclassified
Component: Netigso
7.3
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 00:36 UTC by steveh291
Modified: 2013-07-10 12:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log file from user directory (6.94 KB, text/plain)
2013-01-31 17:39 UTC, steveh291
Details
unzip of requested jar file org.eclipse.osgi_3.8.0.v21020529-1548.jar (357 bytes, text/plain)
2013-01-31 17:42 UTC, steveh291
Details
netigso log from user appdata section (2.20 KB, application/octet-stream)
2013-02-07 16:10 UTC, steveh291
Details
Correct user log (74.40 KB, application/octet-stream)
2013-02-12 17:25 UTC, steveh291
Details
Weaving file in user log area. (357 bytes, text/plain)
2013-02-12 17:26 UTC, steveh291
Details
messages.log recapture from user's directory (129.28 KB, application/octet-stream)
2013-02-13 21:22 UTC, steveh291
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steveh291 2013-01-28 00:36:47 UTC
The netbeans 7.3.1 IDE fails to load. After clicking on the NetBeans IDE icon, the loading process starts and goes through several steps-- the last visible step shown on the splash screen is "Loading modules".  The splash screen then goes away and no other activity occurs.

I looked for some log infomration.   There's a "weavingHookConfigurator" error noted in the netigso log under AppData/Local/NetBeans/Cache/7.3beta2/netigso.  See below.
 
I've tried re-installing netbeans 7.3.1 and this doesn't resolve the issue.  I've been using 7.3.1 beta 2 successfully for a few weeks.  This just started occuring yesterday.  A few days earlier I had been running MPLAB X IDE v1.40 which is based on a custom installation of Netbeans-- I suspect this may be a direct or in-direct cause of the problem.  

This condition is preventing any use of 7.3.1 and there is no obvious way to work around the issue.  This problem does not occur with Netbeans IDE 7.2.1 which is also installed on the workstation.

!SESSION 2013-01-27 17:05:22.066 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_07
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

!ENTRY org.eclipse.osgi 4 0 2013-01-27 17:05:22.066
!MESSAGE error loading hook: org.eclipse.osgi.internal.baseadaptor.weaving.WeavingHookConfigurator
!STACK 0
java.lang.ClassNotFoundException: org.eclipse.osgi.internal.baseadaptor.weaving.WeavingHookConfigurator starting from ModuleCL@13f77c71[org.netbeans.modules.netbinox] with possible defining loaders null and declared parents [ModuleCL@37af5cd6[org.netbeans.libs.osgi], org.netbeans.MainImpl$BootClassLoader@5330f672, ModuleCL@4d12e6ef[org.netbeans.core.netigso]]
	at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:228)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:186)
	at org.eclipse.osgi.baseadaptor.HookRegistry.loadConfigurators(HookRegistry.java:176)
	at org.eclipse.osgi.baseadaptor.HookRegistry.initialize(HookRegistry.java:100)
	at org.eclipse.osgi.baseadaptor.BaseAdaptor.<init>(BaseAdaptor.java:98)
	at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.internalInit(EquinoxLauncher.java:67)
	at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.init(EquinoxLauncher.java:37)
	at org.eclipse.osgi.launch.Equinox.init(Equinox.java:178)
	at org.netbeans.modules.netbinox.Netbinox.init(Netbinox.java:84)
	at org.netbeans.core.netigso.Netigso.prepare(Netigso.java:166)
	at org.netbeans.NetigsoHandle.turnOn(NetigsoHandle.java:125)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:1167)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:1002)
	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
	at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
	at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:296)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:169)
	at org.netbeans.core.startup.Main.start(Main.java:305)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
	at java.lang.Thread.run(Thread.java:722)
Comment 1 Jaroslav Tulach 2013-01-28 11:53:01 UTC
We don't have any 7.3.1 IDE.
Comment 2 steveh291 2013-01-29 18:30:22 UTC
I mis-selected the version.  This occurs with NetBeans IDE 7.3 Beta 2.
Comment 3 Jaroslav Tulach 2013-01-31 08:32:54 UTC
I guess your report has to do something with WeavingHookConfigurator. I can find it in my installation as

$ cd netbeans/platform/modules/ext
$ unzip -v org.eclipse.osgi_3.8.0.v20120529-1548.jar | grep Weaving
    9074  Defl:N     2843  69% 2012-05-29 19:40 98d7b535  org/eclipse/osgi/internal/baseadaptor/weaving/WeavingHookConfigurator.class
     647  Defl:N      364  44% 2012-05-29 19:40 79362aad  org/osgi/framework/hooks/weaving/WeavingException.class
     203  Defl:N      147  28% 2012-05-29 19:40 1c4cbac8  org/osgi/framework/hooks/weaving/WeavingHook.class

can you also see the JAR and verify WeavingHookConfigurator is there? 

Please also attach messages.log and updater.log from your user directory. Reopen with new information.
Comment 4 steveh291 2013-01-31 17:39:46 UTC
Created attachment 130903 [details]
messages.log file from user directory

Messages.log and updater.log as requested
Comment 5 steveh291 2013-01-31 17:42:55 UTC
Created attachment 130904 [details]
unzip of requested jar file org.eclipse.osgi_3.8.0.v21020529-1548.jar

Matches what was found on evaluator's email.
Comment 6 steveh291 2013-01-31 17:52:23 UTC
Unfortunately there doesn't appear to be any updater logs under NetBeans/7.3beta2/var/log -- just messages.log* files.   I also looked under my NetBeans/7.2.1/var/log and didn't notice any updater logs there, either.  Are they located somewhere else?
Comment 7 Jaroslav Tulach 2013-02-04 08:53:24 UTC
> Unfortunately there doesn't appear to be any updater logs under
> NetBeans/7.3beta2/var/log -- just messages.log* files.   I also looked under my
> NetBeans/7.2.1/var/log and didn't notice any updater logs there, either.  Are
> they located somewhere else?

The updater.log should be next to the messages.log. If it is not there, it means you have not used Tools/Plugins to download anything (a common source of problems of this kind). That means your problem is different.

> unzip of requested jar file org.eclipse.osgi_3.8.0.v21020529-1548.jar

Looks OK. The classes seem to be available.

> Created attachment 130903 [details]
> messages.log file from user directory

The messages.log is almost empty and it does not contain any error related to classloading. No "ClassNotFoundException: org.eclipse.osgi.internal.baseadaptor.weaving.WeavingHookConfigurator" - does that mean your problem is gone? Or the exception in your original report was not printed into messages.log?
Comment 8 steveh291 2013-02-04 20:01:12 UTC
The exception in the initial report is not printed in the message log.  The "weavingHookConfigurator" erros is in the netigso log as described in the defect.    The issue is easily reproduced on my system and is still occurring.  Let me know next steps.
Comment 9 Jaroslav Tulach 2013-02-06 11:26:54 UTC
Try to run with -J-Dorg.netbeans.JarClassLoader.level=FINE and share the log output, please.
Comment 10 steveh291 2013-02-07 16:09:03 UTC
I'm not sure if this is the right procedure-- please verify as I'm relatively new to netbeans development but I did the following:

1) in admin mode, used NotePad++ to modify C:\Program Files\NetBeans 7.3 Beta 2\etc\netbeans.conf and edited a line in that file to be as follows and saved the file.

netbeans_default_options="-J-client -J-Dorg.netbeans.JarClassLoader.level=FINE -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.zip.disableMemoryMapping=true -J-Dsun.awt.disableMixing=true -J-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes"

2) I re-started NetBeans 7.3 beta 2 and noticed that the messages.log file under C:\Program Files\NetBeans 7.3 beta2\nb\var\log was unchanged.

3) I confirmed that the there's a "weavingHookConfigurator" error
noted in the netigso log under <my user id>/AppData/Local/NetBeans/Cache/7.3beta2/netigso but the date is now today's date (e.g. the attachment file you have is identical after having added the option you requested.  I've attached that file.
Comment 11 steveh291 2013-02-07 16:10:57 UTC
Created attachment 131113 [details]
netigso log from user appdata section

See comment above.
Comment 12 Jaroslav Tulach 2013-02-12 11:37:14 UTC
Please attach log file from your user directory. See 
http://wiki.netbeans.org/FaqLogMessagesFile
Comment 13 steveh291 2013-02-12 17:25:36 UTC
Created attachment 131312 [details]
Correct user log

Attaching user log as requested from ..\AppData\Roaming\NetBeans\7.2\var\log\messages.log
Comment 14 steveh291 2013-02-12 17:26:23 UTC
Created attachment 131313 [details]
Weaving file in user log area.

Weaving information from user log
Comment 15 Jaroslav Tulach 2013-02-13 07:26:38 UTC
The log file does not contain any exception! How can that happen!? Please generate new log with additional logger turned on:

-J-Dorg.netbeans.modules.netbinox.level=FINE

But I admit, I have no clue, what is going on.
Comment 16 steveh291 2013-02-13 21:22:04 UTC
Created attachment 131363 [details]
messages.log recapture from user's directory

Repeat of startup defect messages.log from user directory
Comment 17 steveh291 2013-02-13 21:29:02 UTC
Made change to conf file as requested and attached the requested log file.  I just re-verified the same behavior-- however I watched very carefully and the sequence is:  "reading module storage",  "loading modules", "turning on modules", "loading module services",  "loading modules" then extremely briefly for less than 100 mS it looks like "starting modules" appears-- then the entire dialog goes away.  At this point there is nothing showing up in either the windows task manager "Application" nor "processes" related to Netbeans.
Comment 18 Jaroslav Tulach 2013-02-15 11:23:28 UTC
No exception in the log again! I don't believe this is a common bug (if it is a bug at all).

Are you saying the NetBeans process dies?

If you want, you can debug the process, put breakpoint to java.lang.System.exit or java.lang.Runtime.exit and find out what is the stacktraces that kills the process. And then put breakpoint there and find what caused that problem, etc., etc.
Comment 19 steveh291 2013-03-12 04:23:20 UTC
I did further investigation and discovered that an upgrade to a newer version of "Constant Guard" caused the issue.  It had a setting to disable the execution of several key java components that was applied by default.  When I went in and Turning off the blocking of these programs (such as java.exe) enabled the correct startup of the besta software.  I have no idea why the earlier version of netbeans would run successfully.
Comment 20 Jaroslav Tulach 2013-07-10 12:27:56 UTC
OK, so this is in fact not a bug in NetBeans, but rather a configuration issue in your operating system. Closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo