Bug 225366 - NetBeans quit unexpectedly while using the liblwawt.dylib plug-in
NetBeans quit unexpectedly while using the liblwawt.dylib plug-in
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
Macintosh Mac OS X
: P3 with 4 votes (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
http://bugs.sun.com/bugdatabase/view_...
jdk_bug_8008543
:
: 237116 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-26 04:32 UTC by jag
Modified: 2013-10-15 08:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
MacOS crash report text (93.38 KB, text/plain)
2013-01-29 04:46 UTC, ebakke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jag 2013-01-26 04:32:07 UTC
I've been getting this OS X JVM crash a lot.  It's certainly a JVM bug and not a NetBeans bug, but it's not clear when the JVM crew will get around to dealing with it and it seems to have been aggravated by recent changes to NetBeans.  Doesn't happen with 7.2


Process:         java [11467]
Path:            /usr/bin/java
Identifier:      org.netbeans.ide.baseide.201301120001
Version:         1.0 (1.0)
Code Type:       X86-64 (Native)
Parent Process:  bash [11236]
User ID:         1528

PlugIn Path:       /Library/Java/JavaVirtualMachines/jdk1.7.0_12.jdk/Contents/Home/jre/lib/lwawt/liblwawt.dylib
PlugIn Identifier: liblwawt.dylib
PlugIn Version:    ??? (1)

Date/Time:       2013-01-25 20:22:27.770 -0800
OS Version:      Mac OS X 10.8.2 (12C60)
Report Version:  10

Interval Since Last Report:          425187 sec
Crashes Since Last Report:           4
Per-App Interval Since Last Report:  411722 sec
Per-App Crashes Since Last Report:   2
Anonymous UUID:                      EC046214-E647-3F93-9F08-8F0B0A34CA6F

Crashed Thread:  0  AppKit Thread  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
*** CFRelease() called with NULL ***

Thread 0 Crashed:: AppKit Thread  Dispatch queue: com.apple.main-thread
0   com.apple.CoreFoundation      	0x00007fff8e37f7d8 CFRelease + 40
1   liblwawt.dylib                	0x00000001601983ff __Java_sun_lwawt_macosx_CWrapper_00024NSObject_release_block_invoke_1 + 91
2   JavaNativeFoundation          	0x000000015b1a35f5 +[JNFRunLoop _performCopiedBlock:] + 20
3   com.apple.Foundation          	0x00007fff97c39677 __NSThreadPerformPerform + 225
4   com.apple.CoreFoundation      	0x00007fff8e389101 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
5   com.apple.CoreFoundation      	0x00007fff8e388a25 __CFRunLoopDoSources0 + 245
6   com.apple.CoreFoundation      	0x00007fff8e3abdc5 __CFRunLoopRun + 789
7   com.apple.CoreFoundation      	0x00007fff8e3ab6b2 CFRunLoopRunSpecific + 290
8   com.apple.HIToolbox           	0x00007fff8b31b0a4 RunCurrentEventLoopInMode + 209
9   com.apple.HIToolbox           	0x00007fff8b31ae42 ReceiveNextEventCommon + 356
10  com.apple.HIToolbox           	0x00007fff8b31acd3 BlockUntilNextEventMatchingListInMode + 62
11  com.apple.AppKit              	0x00007fff93be4613 _DPSNextEvent + 685
12  com.apple.AppKit              	0x00007fff93be3ed2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
13  libosxapp.dylib               	0x0000000160219b56 -[NSApplicationAWT nextEventMatchingMask:untilDate:inMode:dequeue:] + 124
14  com.apple.AppKit              	0x00007fff93bdb283 -[NSApplication run] + 517
15  libosxapp.dylib               	0x00000001602199b9 +[NSApplicationAWT runAWTLoopWithApp:] + 156
16  liblwawt.dylib                	0x000000016017321a -[AWTStarter starter:] + 1591
17  com.apple.Foundation          	0x00007fff97c39677 __NSThreadPerformPerform + 225
18  com.apple.CoreFoundation      	0x00007fff8e389101 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
19  com.apple.CoreFoundation      	0x00007fff8e388a25 __CFRunLoopDoSources0 + 245
20  com.apple.CoreFoundation      	0x00007fff8e3abdc5 __CFRunLoopRun + 789
21  com.apple.CoreFoundation      	0x00007fff8e3ab6b2 CFRunLoopRunSpecific + 290
22  java                          	0x000000010941c422 CreateExecutionEnvironment + 871
23  java                          	0x0000000109416bcc JLI_Launch + 1952
24  java                          	0x000000010941c77f main + 101
25  java                          	0x0000000109416424 start + 52

Thread 1:
0   libsystem_kernel.dylib        	0x00007fff90b6b386 __semwait_signal + 10
1   libsystem_c.dylib             	0x00007fff9325bcbd pthread_join + 847
2   java                          	0x000000010941ba22 ContinueInNewThread0 + 102
3   java                          	0x0000000109417837 ContinueInNewThread + 201
4   java                          	0x000000010941b785 JVMInit + 251
5   java                          	0x00000001094175b5 JLI_Launch + 4489
6   java                          	0x000000010941c77f main + 101
7   java                          	0x000000010941c0b4 apple_main + 92
8   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
9   libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 2:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x0000000109906550 Monitor::wait(bool, long, bool) + 246
6   libjvm.dylib                  	0x00000001099f5e36 Threads::destroy_vm() + 80
7   libjvm.dylib                  	0x000000010981c47d jni_DestroyJavaVM + 223
8   java                          	0x0000000109417b76 JavaMain + 805
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 3:: Dispatch queue: com.apple.libdispatch-manager
0   libsystem_kernel.dylib        	0x00007fff90b6bd16 kevent + 10
1   libdispatch.dylib             	0x00007fff95a4edea _dispatch_mgr_invoke + 883
2   libdispatch.dylib             	0x00007fff95a4e9ee _dispatch_mgr_thread + 54

Thread 4:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 5:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 6:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 7:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 8:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 9:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 10:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 11:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x0000000109923861 os::PlatformEvent::park() + 173
3   libjvm.dylib                  	0x0000000109905b82 ParkCommon(ParkEvent*, long long) + 42
4   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
5   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
6   libjvm.dylib                  	0x000000010979aee6 GCTaskManager::get_task(unsigned int) + 56
7   libjvm.dylib                  	0x000000010979bddb GCTaskThread::run() + 349
8   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
9   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
10  libsystem_c.dylib             	0x00007fff931be181 thread_start + 13

Thread 12:
0   libsystem_kernel.dylib        	0x00007fff90b6b0fa __psynch_cvwait + 10
1   libsystem_c.dylib             	0x00007fff931d5f89 _pthread_cond_wait + 869
2   libjvm.dylib                  	0x000000010992478d os::PlatformEvent::park(long long) + 385
3   libjvm.dylib                  	0x0000000109906374 Monitor::IWait(Thread*, long long) + 160
4   libjvm.dylib                  	0x00000001099065d1 Monitor::wait(bool, long, bool) + 375
5   libjvm.dylib                  	0x0000000109a312ba VMThread::loop() + 444
6   libjvm.dylib                  	0x0000000109a30dd3 VMThread::run() + 121
7   libjvm.dylib                  	0x0000000109927509 java_start(Thread*) + 173
8   libsystem_c.dylib             	0x00007fff931d1742 _pthread_start + 327
9   libsystem_c.dylib             	0x00007fff931be181 thread_start + 13
Comment 1 ebakke 2013-01-29 04:45:49 UTC
I see this crash frequently on my MacBook Air 2012 running NetBeans IDE 7.2, usually after returning from sleep, possibly with a new monitor resolution. I assume it's a JDK bug but I thought I'd vote for it here since there's already a report in the bug database for this. Adding an attachment with my own crash output.
Comment 2 ebakke 2013-01-29 04:46:31 UTC
Created attachment 130759 [details]
MacOS crash report text

See my previous comment.
Comment 3 ebakke 2013-01-29 04:48:04 UTC
By the way, jag comments that it "Doesn't happen with 7.2". I can confirm that it certainly happens on 7.2.1 (my previous comment that I was using 7.2 was wrong--I am using 7.2.1).
Comment 4 scooper4711 2013-01-31 20:19:09 UTC
I just got this on Netbeans 7.3 RC1
Comment 5 cerebrotecnologico 2013-04-01 23:35:40 UTC
I started to get similar crashed when Apple updated my JDK to 1.7.0_17
although the error is another library: libosxapp.dylib


Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.7.0_17; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b02
System: Mac OS X version 10.7.5 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/jmedina/Library/Application Support/NetBeans/7.3
Cache directory: /Users/jmedina/Library/Caches/NetBeans/7.3

It happens every day. Let me know if you want me to collect some files and attach them.
Comment 6 Stanislav Aubrecht 2013-08-01 08:29:59 UTC
It looks like this (unreproducible) JDK bug: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8008543

Reporter, please try running the latest build of JDK 1.8 and reopen if still reproducible, thanks.
Comment 7 rickhillegas 2013-08-09 01:22:20 UTC
This bug reproduces for me using JDK 8. Specifically, I have edited Contents/Resources/NetBeans/etc/netbeans.conf to make the following JDK assignment:

netbeans_jdkhome="/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home"

I am unable to keep netbeans 7.3.1 up longer than a minute before the crash. I think that this bug should be left open to track this defect until the underlying JVM bug is fixed.

Thanks,
-Rick
Comment 8 Stanislav Aubrecht 2013-08-12 07:04:22 UTC
The bug is tracked in JDK bug database. There's nothing we can do on NetBeans side.
Comment 9 Ondrej Brejla 2013-10-15 08:01:08 UTC
*** Bug 237116 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo