Bug 225310 - AssertionError at com.sun.tools.javac.util.Assert.error
AssertionError at com.sun.tools.javac.util.Assert.error
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 23:26 UTC by Ralph Ruijs
Modified: 2015-09-17 11:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.11 KB, text/plain)
2013-01-24 23:26 UTC, Ralph Ruijs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Ruijs 2013-01-24 23:26:20 UTC
Build: NetBeans IDE Dev (Build 20130125-a58a8f4ec026)
VM: OpenJDK 64-Bit Server VM, 23.2-b09, OpenJDK Runtime Environment, 1.7.0_07-b30
OS: Linux

User Comments:
ralphbenjamin: JDK8 build




Stacktrace: 
java.lang.AssertionError
   at com.sun.tools.javac.util.Assert.error(Assert.java:126)
   at com.sun.tools.javac.util.Assert.check(Assert.java:45)
   at com.sun.tools.javac.code.Annotations.setDeclarationAttributes(Annotations.java:101)
   at com.sun.tools.javac.code.Annotations.setAttributes(Annotations.java:119)
   at com.sun.tools.javac.comp.Lower.visitTopLevel(Lower.java:2271)
   at com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:521)
Comment 1 Ralph Ruijs 2013-01-24 23:26:22 UTC
Created attachment 130611 [details]
stacktrace
Comment 2 Martin Balin 2015-09-17 11:20:19 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo