Bug 225285 - Modified Maven Netbeans Module won't reload until full clean & build of the module
Modified Maven Netbeans Module won't reload until full clean & build of the m...
Status: RESOLVED DUPLICATE of bug 221781
Product: apisupport
Classification: Unclassified
Component: Maven
7.2.1
PC Linux
: P3 (vote)
: 7.3
Assigned To: Milos Kleint
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 13:28 UTC by solasola
Modified: 2013-01-24 17:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
error after first reload (6.08 KB, text/plain)
2013-01-24 13:28 UTC, solasola
Details
error after the second reload (3.57 KB, text/plain)
2013-01-24 13:28 UTC, solasola
Details
error_after_second_reload2 (5.09 KB, text/plain)
2013-01-24 13:29 UTC, solasola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description solasola 2013-01-24 13:28:14 UTC
Created attachment 130581 [details]
error after first reload

Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Updates: Updates available
Java: 1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02
System: Linux version 3.5.0-17-generic running on amd64; UTF-8; hu_HU (nb)
User directory: /home/sola/.netbeans/7.2.1
Cache directory: /home/sola/.cache/netbeans/7.2.1

---------
I am developing a Mavenized Platform application.

I have a module (module1) attached to the "app" project of the platform application as a Maven dependency. Module1 is also added as a module to the pom of the "parent" project of the platform application.

Module1 is a very simple project consisting a singleton topcomponent created with the visual designer.

When I modify the code of Module1 (say, change the background color of a label placed in the topcomponent) the following happens:

I build Module1 with "Build".
I call "Reload in target platform":

The text of menu item for the topcomponent (in the "Window" menu) disappears in the running platform application. The menu item stays there but it will not work anymore. There is an error in the "IDE Log" window (attached:error_after_first_reload.txt)

After this, Module1 somehow becomes invalid in the platform application and will not load even after a full restart of the application.

I can fix this only by running a full "Clean & Build" and calling "Reload in target platform" but I still get an error from the platform application in a dialog (attached:error_after_second_reload.txt) and an error in the "IDE log" (attached:error_after_second_reload2.txt).

After this the platform application can be restarted and will start without errors and showing the modified version of Module1.
Comment 1 solasola 2013-01-24 13:28:46 UTC
Created attachment 130583 [details]
error after the second reload
Comment 2 solasola 2013-01-24 13:29:09 UTC
Created attachment 130584 [details]
error_after_second_reload2
Comment 3 Milos Kleint 2013-01-24 13:37:47 UTC
most likely a duplicate of issue 221781, turning Compile on Save off should improve the behaviour of annotations and other things.
Comment 4 solasola 2013-01-24 16:38:31 UTC
Switching "Compile on Save" off and doing a "Clean" on my projects seems to corrected the problem.

After changing the code, a single "Reload on target platform" correctly updates the running platform application.
Comment 5 Milos Kleint 2013-01-24 17:33:48 UTC
please note that in 7.3, CoS is off by default (with exception of web, ejb and ear projects)

*** This bug has been marked as a duplicate of bug 221781 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo