Bug 225164 - UI Components under "Border Property Page" are defective
UI Components under "Border Property Page" are defective
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Property Sheet
7.3
Macintosh Mac OS X
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 04:43 UTC by ytn01
Modified: 2013-04-04 14:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ytn01 2013-01-22 04:43:51 UTC
When opening and editing border properties of a component, it can be seen that some of the ComboBoxs of properties, particularly color related ones, seem to be devective.

Reproducing Steps:
1. Create a Java Application Project,
2. Add a JFrame into it
3. Add a JList into the JFrame.
4. Select the JList & from it's property list, click the ... icon of the border property
5. Select Bevel border from list of border types,... property list for Bevel border will be displayed below
	-issue #1: "bevelType" property, which normally has a corresponding ComboBox for input selection has a TextInput field here.
	-issue #2: The rest of the color related properties also were suppose to be ComboBoxes to quickly pick colors, however they don't work as comboboxes here. But when pressing the "Space" key, the ComboBoxes contents get listed.



Product Version = NetBeans IDE 7.3 RC1 (Build 201301102100)
Operating System = Mac OS X version 10.8.2 running on x86_64
Java; VM; Vendor = 1.7.0_11
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Comment 1 Tomas Pavek 2013-01-22 17:19:16 UTC
This was caused by changes in the property sheet during the 7.3 development. The difference can be seen by comparing with NetBeans 7.2. I agree it is a bug (regression).

As for the first issue, all combo boxes are now editable, which is wrong. This is happening on all places, not just in the border editor. As for the second issue, a noneditable combo box used to appear here when clicking on the "null" value of the color. Now it does not appear on click, but when the user types something.
Comment 2 Stanislav Aubrecht 2013-04-04 14:36:11 UTC
All combo box editors are editable because they support auto-complete.

The combo popup now shows automatically when clicking into the editor: core-main 1f112dcae6cb


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo