Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 225103 - run install chrome extension window option freeze IDE
run install chrome extension window option freeze IDE
Status: VERIFIED WORKSFORME
Product: web
Classification: Unclassified
Component: HTML Project
7.3
PC Linux
: P2 (vote)
: 7.4
Assigned To: Tomas Mysik
issues@web
: REGRESSION
Depends on:
Blocks: 226441
  Show dependency treegraph
 
Reported: 2013-01-19 18:06 UTC by mstarnacki
Modified: 2013-02-25 17:57 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (126.78 KB, image/png)
2013-01-19 18:06 UTC, mstarnacki
Details
log IDE file (44.01 KB, text/plain)
2013-01-19 18:07 UTC, mstarnacki
Details
thread dump first one (33.47 KB, text/plain)
2013-01-19 19:28 UTC, mstarnacki
Details
thread dump second one (30.63 KB, text/plain)
2013-01-19 19:30 UTC, mstarnacki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mstarnacki 2013-01-19 18:06:02 UTC
Created attachment 130400 [details]
screenshot

I have installed chrome. I selected run on project HTML5. In window which appear
"Install Chrome Extension" I can choose "locate" link and always IDE is freezen. Then only kill -9 on IDE process is possible. See screenshot. In log has not any warnig/error issue information.
Comment 1 mstarnacki 2013-01-19 18:07:08 UTC
Created attachment 130401 [details]
log IDE file
Comment 2 Vladimir Riha 2013-01-19 18:49:49 UTC
I tried it on Ubuntu 12.10 it works for me and opens Nautilus. Could you perhaps attach 2-3 thread dumps (say taken in minute interval after each other) when this freeze happens? How to generate thread dump is described [1]. Thanks


[1] http://wiki.netbeans.org/GenerateThreadDump

Product Version: NetBeans IDE 7.3 RC1 (Build 201301102100)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
Runtime: Java(TM) SE Runtime Environment 1.7.0-b147
System: Linux version 3.5.0-18-generic running on amd64; UTF-8; en_US (nb)
Comment 3 mstarnacki 2013-01-19 19:28:50 UTC
Created attachment 130403 [details]
thread dump first one

Dump made before IDE was freezen.
Comment 4 mstarnacki 2013-01-19 19:30:10 UTC
Created attachment 130404 [details]
thread dump second one

Dump made after IDE was freezen.
Comment 5 everflux 2013-01-20 22:47:37 UTC
Worked for me on Ubuntu 12.10 with the dev build about 2 weeks ago.
Comment 6 Petr Jiricka 2013-01-21 09:30:03 UTC
Tomas, could you please help investigate this as you have a Linux machine? Can you reproduce? Also cc'ing Denis as he wrote this code.

everflux, can you please also attach your thread dump? It looks like for mstarnacki, the IDE is stuck in sun.awt.X11.XDesktopPeer.gnome_url_show(Native Method). mstarnacki, which flavor+version of Linux do you use?

Also, did something change in your environment recently? I see from the log file that you are using the latest JDK 7u11 - which version did you use previously, and can you confirm this regressed recently?

I am wondering if desktop.isSupported(Desktop.Action.OPEN) started to return true recently on Linux (see method LinkListener.hyperlinkUpdate) - could that be a problem? Tomas, what is it returning for you? Thanks.
Comment 7 Denis Anisimov 2013-01-21 09:46:19 UTC
The URL open strategy for Linux is implemented by Tomas actually :
http://hg.netbeans.org/web-main/rev/2ec7cab867e0
I've just wrote the original version for link listeners and refactored it later
to LinkListener.java class.
But what I see from the thread dump is :
freeze is inside JDK method java.awt.Desktop.open(Desktop.java:272)
(which delegates the call to the native method sun.awt.X11.XDesktopPeer.gnome_url_show). And there is no any NB specific code involvement. So it seems this is JDK issue.

To avoid NB freeze we could move out the non-UI logic inside LinkListener.hyperlinkUpdate to separate  non-Swing thread.
At least it will allow to avoid NB freeze.
Comment 8 Tomas Mysik 2013-01-21 10:20:33 UTC
I cannot reproduce this issue (but I am using latest stable Kubuntu).

As Denis wrote, the "freeze" is in:

sun.awt.X11.XDesktopPeer.gnome_url_show(Native Method)

I don't know what exactly it calls, I will try to have a look. Meanwhile - @reporter, what will happen if you run "xdg-open file:///home" in your terminal?

Thanks.

Product Version: NetBeans IDE Dev (Build 20130118-90f70530a078)
Java: 1.6.0_38; Java HotSpot(TM) 64-Bit Server VM 20.13-b02
Runtime: Java(TM) SE Runtime Environment 1.6.0_38-b05
System: Linux version 3.5.0-22-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 9 Tomas Mysik 2013-01-21 10:22:52 UTC
@reporter: Also, please try to use JDK 6 if you are on JDK 7 (and vice versa) so we can find out whether the problem is in the JDK or (perhaps just your?) Gnome installation.

Thanks a lot for your cooperation.
Comment 10 Petr Jiricka 2013-01-21 10:23:25 UTC
Adding information that I received offline from mstarnacki:

> mstarnacki, which flavor+version of Linux do you use?
 
I work with Debian Squeeze 2.6.32-5-686.

> you are using the latest JDK 7u11 - which version did you use
> previously, and can you confirm this regressed recently?

I am at work now. I have installed netbeans 7.3 RC1 and jdk1.7_11 on different machine with the same system version and core. On the 2nd machine bug disappear. After link selection I have explorer window with plugin file.
Machine with bug was upgraded and the 2nd was installed pure system. Maybe it is problem with some linux packages?
Comment 11 Tomas Mysik 2013-01-21 10:27:14 UTC
BTW it seems that JDK calls this method [1].

[1] http://developer.gnome.org/libgnome/stable/libgnome-gnome-url.html#gnome-url-show
Comment 12 Tomas Mysik 2013-01-21 10:35:50 UTC
Since we cannot reproduce it (even reporter cannot on one of his PCs), closing as WORKSFORME, sorry.

BTW I have submitted issue #225130 to avoid blocking UI thread.

Thanks for reporting.
Comment 13 Tomas Mysik 2013-01-21 10:46:07 UTC
Just got private e-mail from starnacki@gmail.com:

Hi,
I do not why but I checked this bug with clear user dir and cache with jdk1.6_22 and 1.7_11 today and it feature works fine. Explorer is open with plugin file. So I can not reproduce it now.
Comment 14 tha_specializt 2013-02-25 17:53:36 UTC
*** Bug 226441 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo