Bug 22510 - XML Document Formatting and Indentation
XML Document Formatting and Indentation
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Text-Edit
-FFJ-
All All
: P2 with 10 votes (vote)
: 5.x
Assigned To: issues@xml
issues@xml
plan lines=3000 duration=10 4.2-candi...
:
: 15749 27269 30235 31708 33340 41309 43329 49232 55097 (view as bug list)
Depends on: 31726
Blocks: 32047
  Show dependency treegraph
 
Reported: 2002-04-16 17:33 UTC by Merline Saintil
Modified: 2007-09-25 01:33 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Merline Saintil 2002-04-16 17:33:02 UTC
I'd like to request an enhancement for the feature
of formatting XML file  which user created
originally as below.,

before:
<xxx>
  <yyy>
</yyy></xxxx>

after:
<xxx>
    <yyy>
    </yyy>
</xxx>
If FFJ4.0 has this feature,
please let me know how to do this.
Comment 1 Jan Lahoda 2002-04-17 08:40:46 UTC
XML module should support this.
Comment 2 _ pkuzel 2002-06-03 12:28:05 UTC
Let these are considered while planning next release.
Comment 3 Marek Grummich 2002-07-19 16:34:39 UTC
Target milestone was changed from not determined to TBD
Comment 4 _ pkuzel 2002-08-13 21:52:26 UTC
Such feature was removed, because it requires 
hints from user to work properly. We have not 
yet agreed what minimal set of hints is 
needed. 
 
Subtask of issue 15749. 
Comment 5 _ lkramolis 2002-10-02 10:31:06 UTC
*** Issue 27269 has been marked as a duplicate of this issue. ***
Comment 6 _ lkramolis 2002-10-02 10:31:33 UTC
*** Issue 15749 has been marked as a duplicate of this issue. ***
Comment 7 _ pkuzel 2003-03-06 11:05:46 UTC
*** Issue 31708 has been marked as a duplicate of this issue. ***
Comment 8 _ pkuzel 2003-03-06 11:10:39 UTC
We need hints to distingwish content-WS and indentation-WS. Now I
realized that JTidy would not probably understand namespaces. It's 99%
solution if we leverage it.

JTidy takes hints in form of CSS. I'll raise that question a W3C CSS
mailing lists. 
Comment 9 _ pkuzel 2003-03-06 11:14:20 UTC
CSS level 3 may cover it:
http://lists.w3.org/Archives/Public/www-style/1999Sep/0130.html
Comment 10 _ pkuzel 2003-03-14 21:21:55 UTC
*** Issue 30235 has been marked as a duplicate of this issue. ***
Comment 11 Martin Schovanek 2003-05-05 09:32:33 UTC
*** Issue 33340 has been marked as a duplicate of this issue. ***
Comment 12 dmladek 2004-08-04 16:22:50 UTC
I guess it was not implemented yet (even in 3.6) thus changing
TargetMilestone from 3.6 to TBD


BTW: it has so many duplicates that P4 is inadequate IMHO.
Changing it to P2
Comment 13 dmladek 2004-08-04 16:26:18 UTC
isn't it strange marking this issue as subtask of issue #15749 which
is a dup of this one?

Please, see 

>------- Additional Comments From Petr Kuzel 2002-08-13 13:52 PDT >-------

>Such feature was removed, because it requires 
>hints from user to work properly. We have not 
>yet agreed what minimal set of hints is 
>needed. 
> 
>Subtask of issue 15749. 
Comment 14 dmladek 2004-08-04 16:44:38 UTC
because issue #15749 has been marked as dup of this one, thus
this issue can't depend on it. I removing it (issue #15749) from
dependant list
Comment 15 Jesse Glick 2004-09-29 18:06:59 UTC
*** Issue 49232 has been marked as a duplicate of this issue. ***
Comment 16 aldobrucale 2005-01-14 16:45:01 UTC
*** Issue 43329 has been marked as a duplicate of this issue. ***
Comment 17 zikmund 2005-02-17 12:16:07 UTC
*** Issue 41309 has been marked as a duplicate of this issue. ***
Comment 18 zikmund 2005-02-17 12:16:22 UTC
*** Issue 55097 has been marked as a duplicate of this issue. ***
Comment 19 Jiri Kovalsky 2005-05-09 15:23:33 UTC
Please take this RFE into account when planning new features into next release.
Together with #22510 this is one of two top required enhancements.
Comment 20 nightfears 2005-05-09 15:51:54 UTC
"Together with #22510 this is one of two top required enhancements."
-- you probably meant #17588
Comment 21 Jiri Kovalsky 2005-05-09 20:00:49 UTC
No, I actually meant the #26477. I was not specific enough since I was reviewing
all RFEs filled against XML module. Sorry for confusion and thanks for the
correction ...
Comment 22 Marek Fukala 2005-08-24 13:42:47 UTC
fixed
Comment 23 Marek Fukala 2005-08-24 14:14:56 UTC
mistakenly closed.
Comment 24 Marek Fukala 2005-08-24 14:56:49 UTC
OK. Let's handle this issue finally...

The original usecase from 119304 (Merline Saintil) is not exactly what this
issue claims in the summary. Since I implemented the XML formatting and
indentation engine (even not hadling the original usecase) I am closing this
issue since IMO the 22 votes was added not to the usecase, but to the missing
indentation and formatting. 

Merline, if you really want to fix you usecase, please fill a separate issue for it.
Comment 25 Jiri Kovalsky 2005-08-24 15:13:07 UTC
Verifying. If you insist on your very first usecase Merline, don't hesitate to
file new RFE regarding the requirement.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo