Bug 225085 - Pasting code from copy and paste history does not offer to add java imports
Pasting code from copy and paste history does not offer to add java imports
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Navigation
7.3
PC Windows 7
: P3 (vote)
: 7.3.1
Assigned To: Milutin Kristofic
issues@editor
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-19 08:52 UTC by sreimers
Modified: 2013-05-06 13:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2013-01-19 08:52:41 UTC
Just copy and paste Java code into a Java file offers to autmatically do the necessary imports. Using an entry from the copy and paste history the dialog offering the imports is not displayed. Workaround: Fix Imports.
Comment 1 Jiri Prox 2013-01-21 10:21:24 UTC
Reproducible
Comment 2 Milutin Kristofic 2013-02-26 11:55:21 UTC
http://hg.netbeans.org/jet-main/rev/954a9c9a7999
Comment 3 Quality Engineering 2013-02-27 16:14:34 UTC
Integrated into 'main-golden', will be available in build *201302270948* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/954a9c9a7999
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #225085 - Pasting code from copy and paste history does not offer to add java imports
Comment 4 Milutin Kristofic 2013-03-12 10:01:43 UTC
This change won't be included in netbeans patch, but next netbeans version. The change needs to be tested longer, since change is a little risky.
Comment 5 Marian Mirilovic 2013-03-12 11:59:07 UTC
Ok, targeting NB 7.3.1 (as the next NB release).

BTW: not sure what are the exact steps to reproduce, but I was not able to do so even in NB 7.3 ;(    

Jirka (Prox), could you please verify ? Thanks in advance.
Comment 6 Jiri Prox 2013-03-12 13:37:35 UTC
verified


Product Version: NetBeans IDE Dev (Build 20130312-2c21fe2d19b2)
Updates: Updates available
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b19
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b78
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
User directory: C:\Users\jprox\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\jprox\AppData\Local\NetBeans\Cache\dev
Comment 7 Milutin Kristofic 2013-05-02 15:00:30 UTC
Transplanted http://hg.netbeans.org/releases/rev/c1437e621670


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo