Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 225053 - error: unmappable character for encoding UTF-8 * <p>Java-Klasse f?r [class name goes here] complex type.
error: unmappable character for encoding UTF-8 * <p>Java-Klasse f?r [class n...
Status: RESOLVED DUPLICATE of bug 226833
Product: javaee
Classification: Unclassified
Component: Code
7.2.1
PC Windows 7
: P3 with 1 vote (vote)
: TBD
Assigned To: issues@javaee
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 10:43 UTC by sunwasbetterthanoracle
Modified: 2013-05-14 09:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (85.96 KB, text/plain)
2013-01-18 10:43 UTC, sunwasbetterthanoracle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunwasbetterthanoracle 2013-01-18 10:43:15 UTC
Product Version = NetBeans IDE 7.2.1 (Build 201210100934)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_07
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.3-b01

In a Java SE application when I create a web service client, have netbeans create the complex type classes from the wsdl and run the application I get this error for each and every class in wsdl:
error: unmappable character for encoding UTF-8
 * <p>Java-Klasse f?r allVisitors complex type.

And this is what the class looks like:

package de.versatec.zaesa.webservicetester;

import javax.xml.bind.annotation.XmlAccessType;
import javax.xml.bind.annotation.XmlAccessorType;
import javax.xml.bind.annotation.XmlType;


/**
 * <p>Java-Klasse f�r allVisitors complex type.
 * 
 * <p>Das folgende Schemafragment gibt den erwarteten Content an, der in dieser Klasse enthalten ist.
 * 
 * <pre>
 * &lt;complexType name="allVisitors">
 *   &lt;complexContent>
 *     &lt;restriction base="{http://www.w3.org/2001/XMLSchema}anyType">
 *       &lt;sequence>
 *       &lt;/sequence>
 *     &lt;/restriction>
 *   &lt;/complexContent>
 * &lt;/complexType>
 * </pre>
 * 
 * 
 */
@XmlAccessorType(XmlAccessType.FIELD)
@XmlType(name = "allVisitors")
public class AllVisitors {


}

Notice the weird character at 'Java-Klasse f_r allVisitors complex type'? I assume netbeans tried to insert an 'ü' here and failed miserably at that.
Workaraound: Open up each generated class file and delete the weird character - it is inside a comment tag, anyway.
Comment 1 sunwasbetterthanoracle 2013-01-18 10:43:21 UTC
Created attachment 130354 [details]
IDE log
Comment 2 markiewb 2013-05-13 21:00:36 UTC
Duplicate of [1] 

File your details at [1] and reopen the issue [1]

[1] https://netbeans.org/bugzilla/show_bug.cgi?id=226833

*** This bug has been marked as a duplicate of bug 226833 ***
Comment 3 Sergey Petrov 2013-05-14 09:52:24 UTC
this issue was reported againts 7.2.1 and https://netbeans.org/bugzilla/show_bug.cgi?id=216526 was fixed in 7.3, it may not be nice to reopen 226833 is the issue isn't reproducible in 7.3, please check 7.3 first.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo