Bug 224876 - Generating a JAX-RS client on a non-english system generates uncompilable code
Generating a JAX-RS client on a non-english system generates uncompilable code
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: REST
7.3
PC Windows 7
: P2 (vote)
: 7.3
Assigned To: Denis Anisimov
issues@webservices
: 73_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 20:49 UTC by markiewb
Modified: 2013-01-22 08:40 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Shows the errors in output window and non-compilable code (397.70 KB, image/png)
2013-01-14 20:50 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2013-01-14 20:49:12 UTC
[ BUILD # : 201301102100 ]
[ JDK VERSION : 1.7.0_09 ]

Reproduction
* start NetBeans on a non-english system (f.e. with german locale)
* create "new java web app" using "new project..." wizard
* create "restful java client" using "new file..." wizard
* choose IDE registered webservice "Amazon/EC2 Service" and let the 
client be generated

ACTUAL: the generated client code is not compilable, because it contains 
non-UTF8-chars. Opening a generated file warns about non-UTF8-
encoding - see screenshot
EXPECTED: the generated client is compilable

IMHO this is a major showblocker. Any user without english locale (f.e. 
german with umlauts) will run into this issue. It is reproducible every time. 
That is why i set it to P2

FYI 1: I tried to reproduce it also with JAX-WS. There are no encoding 
errors when generating a JAX-WS-client. You generate them via " wsimport -
d ... -encoding UTF-8 ..."

FYI 2: You already fixed a similar JAXWS-encoding bug at 
* http://netbeans.org/bugzilla/show_bug.cgi?id=182984
* http://netbeans.org/bugzilla/show_bug.cgi?id=216899
by explicit definition of the encoding in the build files

----

Product Version: NetBeans IDE 7.3 RC1 (Build 201301102100)
Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Windows 7 version 6.1 running on amd64; Cp1252; de_DE (nb)
Comment 1 markiewb 2013-01-14 20:50:14 UTC
Created attachment 130213 [details]
Shows the errors in output window and non-compilable code
Comment 2 Denis Anisimov 2013-01-15 13:23:50 UTC
web-main#fd2ffc6c93fd
Comment 3 Quality Engineering 2013-01-16 02:43:48 UTC
Integrated into 'main-golden', will be available in build *201301160001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/fd2ffc6c93fd
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#224876 - Generating a JAX-RS client on a non-english system generates uncompilable code
Comment 4 Jiri Skrivanek 2013-01-16 13:34:58 UTC
I tried dev build 201301160001 and the fix seems to be OK. I agree to
transplant it to release73 branch.
Comment 5 Denis Anisimov 2013-01-21 15:24:47 UTC
releases#8a2517cfd191 ( release73 )
Comment 6 Quality Engineering 2013-01-22 00:15:00 UTC
Integrated into 'releases', will be available in build *201301212100* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/8a2517cfd191
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#224876 - Generating a JAX-RS client on a non-english system generates uncompilable code in release73 branch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo