Bug 224873 - java.net.ConnectException at org.netbeans.modules.nativeexecution.api.util.HostInfoUtils.fileExists
java.net.ConnectException at org.netbeans.modules.nativeexecution.api.util.Ho...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: execution
7.3
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
dlight-issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 20:38 UTC by Exceptions Reporter
Modified: 2016-12-12 09:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.65 KB, text/plain)
2013-01-14 20:38 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-01-14 20:38:06 UTC
This issue was reported manually by vv159170.
It already has 1 duplicates 


Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.0-b11, Java(TM) SE Runtime Environment, 1.6.0_25-b06
OS: Windows 7

Stacktrace: 
java.net.ConnectException
   at org.netbeans.modules.nativeexecution.api.util.HostInfoUtils.fileExists(HostInfoUtils.java:109)
   at org.netbeans.modules.cnd.discovery.buildsupport.BuildProjectActionHandler$ExecLogWrapper.downloadExecLog(BuildProjectActionHandler.java:260)
   at org.netbeans.modules.cnd.discovery.buildsupport.BuildProjectActionHandler$ExecLogWrapper.getExecLog(BuildProjectActionHandler.java:284)
   at org.netbeans.modules.cnd.discovery.buildsupport.BuildProjectActionHandler.reconfigureCodeAssistance(BuildProjectActionHandler.java:215)
   at org.netbeans.modules.cnd.discovery.buildsupport.BuildProjectActionHandler.access$200(BuildProjectActionHandler.java:75)
   at org.netbeans.modules.cnd.discovery.buildsupport.BuildProjectActionHandler$1.executionFinished(BuildProjectActionHandler.java:205)
Comment 1 Exceptions Reporter 2013-01-14 20:38:07 UTC
Created attachment 130210 [details]
stacktrace
Comment 2 Maria Tishkova 2013-05-17 10:02:51 UTC
moved to execution sub-component as dlight is gone from the NetBeans
Comment 3 Maria Tishkova 2013-05-17 13:16:03 UTC
There is no way to protect the code from the connection lost, so will throw exception as it is done now.
Comment 4 Vladimir Kvashin 2016-11-02 14:05:07 UTC
I'm getting this "red brick message" many times.
We should just handle the exception differently.
Comment 5 Vladimir Kvashin 2016-11-02 16:34:04 UTC
Fixed in 081c6acc304a at enum/r82
Comment 6 Quality Engineering 2016-11-10 03:22:26 UTC
Integrated into 'main-silver', will be available in build *201611100001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/1ac6f1533a1d
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #224873 - java.net.ConnectException at org.netbeans.modules.nativeexecution.api.util.HostInfoUtils.fileExists
(transplanted from 081c6acc304aa16e68557f30bda498f3924cafa3)
Comment 7 soldatov 2016-12-12 09:01:56 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo