Bug 22481 - Line numbers in diff
Line numbers in diff
Status: VERIFIED FIXED
Product: utilities
Classification: Unclassified
Component: Diff
3.x
PC All
: P3 with 1 vote (vote)
: 3.x
Assigned To: Martin Entlicher
diff-issues@utilities
: UI
: 29767 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 10:01 UTC by David Hall
Modified: 2004-03-03 23:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Editor text properties (293 bytes, text/plain)
2003-01-03 15:21 UTC, _ gtzabari
Details
Font color properties (649 bytes, text/plain)
2003-01-03 15:22 UTC, _ gtzabari
Details
Editor x-java properties (325 bytes, text/plain)
2003-01-03 15:23 UTC, _ gtzabari
Details
The contextual diff, that fix this problem. (10.19 KB, patch)
2003-07-24 17:29 UTC, Martin Entlicher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Hall 2002-04-16 10:01:25 UTC
I have changed my default font for the Java Editor to 
Arial 12 and the line Height Correction to 0.9 so that I 
can get more lines on the editor. When doing a diff this 
has the effect of making the diff line numbers not have 
the same line spacing as the source code lines next to 
them. The normal java source code editor seems fine with 
these settings.
Comment 1 dmladek 2002-04-29 17:17:15 UTC
Althought the user hasn't specified closer any OS/JDK/IDE environment
I could recomand you look at those JDK bugs (for 1.4.x):

http://developer.java.sun.com/servlet/SessionServlet?url=http://developer.java.sun.com/developer/bugParade/bugs/4470394.html
http://developer.java.sun.com/servlet/SessionServlet?url=http://developer.java.sun.com/developer/bugParade/bugs/4469005.html

The first one is related to troubles (font's height) when you change
color of fonts in the IDE under jdk1.3 and then migrate to jdk1.4

that's my 2 Kc:-)
Comment 2 Filip Rachunek 2002-05-03 08:03:16 UTC
UI keyword added.
Comment 3 Marek Grummich 2002-07-22 09:46:00 UTC
Set target milestone to TBD
Comment 4 Jiri Kovalsky 2002-07-22 16:53:29 UTC
I am convinced that this is frequent operation and users should be
warned about it.
Comment 5 Martin Entlicher 2003-01-03 14:47:52 UTC
*** Issue 29767 has been marked as a duplicate of this issue. ***
Comment 6 _ gtzabari 2003-01-03 15:21:43 UTC
Created attachment 8427 [details]
Editor text properties
Comment 7 _ gtzabari 2003-01-03 15:22:17 UTC
Created attachment 8428 [details]
Font color properties
Comment 8 _ gtzabari 2003-01-03 15:23:44 UTC
Created attachment 8429 [details]
Editor x-java properties
Comment 9 _ gtzabari 2003-01-03 15:25:49 UTC
The above attachements are my Editor settings which should allow you
to easily reproduce this problem.

1) This was reproduced under the 3.4 dev builds
2) I hope you plan on fixing this bug in 3.4 dev? I can help reproduce
and verify.
Comment 10 Martin Entlicher 2003-01-03 15:50:19 UTC
Thanks for the editor settings.

I'm afraid it's too late to fix this into 3.4 codebase. FCS is planned
on Jan 15. If you really need this to be fixed in 3.4.1, I'll ask
Maxym (the 3.4.1 release coordinator) when is the last day for
integrations into 3.4.1.

Comment 11 Martin Entlicher 2003-06-26 10:49:51 UTC
Changing OS to "All", it affects all OS. Working on a fix...
Comment 12 Martin Entlicher 2003-06-26 12:45:46 UTC
The bug is fixed in the main trunk and projects branch:

Checking in LinesComponent.java;
/cvs/diff/src/org/netbeans/modules/diff/builtin/visualizer/LinesComponent.java,v 
<--  LinesComponent.java
new revision: 1.5; previous revision: 1.4

Checking in LinesComponent.java;
/cvs/diff/src/org/netbeans/modules/diff/builtin/visualizer/LinesComponent.java,v 
<--  LinesComponent.java
new revision: 1.4.78.1; previous revision: 1.4
Comment 13 dmladek 2003-07-15 14:47:57 UTC
For me it's OK in NB351-RC1 #200307142351 and jdk1.4.2 and with Gili
editor's settings
Comment 14 Martin Entlicher 2003-07-24 17:29:18 UTC
Created attachment 11121 [details]
The contextual diff, that fix this problem.
Comment 15 Martin Entlicher 2003-07-31 15:15:40 UTC
The fix was merged into release35_fixes branch:

Checking in
src/org/netbeans/modules/diff/builtin/visualizer/LinesComponent.java;
/shared/data/helm/cvs/repository/diff/src/org/netbeans/modules/diff/builtin/visualizer/LinesComponent.java,v 
<--  LinesComponent.java
new revision: 1.4.88.1; previous revision: 1.4
done
Comment 16 Jiri Kovalsky 2003-11-04 14:40:22 UTC
Confirmed as fixed in Sun ONE Studio 5.0 patched with Update 1.
Comment 17 Antonin Nebuzelsky 2003-11-04 15:05:51 UTC
Fixed also in Nevada Patch 1 and in Arrow. (And confirmed verified by
Jirka above...)
Comment 18 dmladek 2003-11-06 16:41:17 UTC
I've verified a fix also on Sparc-Solaris 8 and Arrow build #031024_1)
using jdk1.4.2_02
Comment 19 dmladek 2003-11-07 15:53:00 UTC
verified also on RH 9 linux (Arrow build #031024_1, using jdk1.4.2_02)
Comment 20 Patrick Keegan 2004-03-03 23:10:16 UTC
removing RELNOTE keyword


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo