Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 224794 - Nested php and html project: Commit of parent project does not show changed files from nested project
Nested php and html project: Commit of parent project does not show changed f...
Status: RESOLVED DUPLICATE of bug 159543
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
7.3
PC Linux
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-12 18:50 UTC by everflux
Modified: 2013-01-12 18:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description everflux 2013-01-12 18:50:17 UTC
[ BUILD # : 201301102100 ]
[ JDK VERSION : other ]

I have a parent project with a nested project
/ [php project]
/admin/ [html project]

When files in the nested project are changed, the "Source Files" entry of the
parent project is assigned the blue container icon correctly, the parent
project icon stays unchanged.

When I want to commit all changes from the parent project - including the
nested project - and I right-click on the parent project, select
"mercuial->commit..." no changes from the nested project are shown.
When I right click on the "source files" entry of the parent project, all
changes, including the nested project are shown.
I tried to look up that behaviour in the documentation, but without success. I
am not sure whether this is a bug or a feature. I think this is at least
inconsistent and might confuse some users.
Comment 1 Ondrej Vrabec 2013-01-12 18:55:32 UTC
The project view is a logical view and project nodes are logical nodes, operations done on such a node do not affect other projects. So a parent project is completely independent project and does not involve its subprojects (or nested projects). Simply select all projects you want to commit and run Mercurial -> Commit on all of them

*** This bug has been marked as a duplicate of bug 159543 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo