Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 224790 - Nested Javascript and PHP projects: Focus put on wrong project after file creation
Nested Javascript and PHP projects: Focus put on wrong project after file cre...
Status: RESOLVED DUPLICATE of bug 224799
Product: php
Classification: Unclassified
Component: Project
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-12 18:04 UTC by everflux
Modified: 2013-01-14 10:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description everflux 2013-01-12 18:04:52 UTC
[ BUILD # : 201301102100 ]
[ JDK VERSION : other ]

I have two projects, a PHP project and an HTML5 project.
Layout:
/ [php project]
/admin/
/admin/htmlclient [html project]

When creating a new file in "admin" and I choose the PHP project the correct
file types are displayed, creating a PHP file the file is correctly created,
but Netbeans switches to the nested project now, forcing me to scroll up to the
correct place.

I would expect Netbeans to select me the newly created PHP file in the PHP
project.
Comment 1 Milos Kleint 2013-01-12 18:47:42 UTC
what package/folder did you create your file in?
Comment 2 everflux 2013-01-12 18:52:41 UTC
I created a PHP file by browsing in the parent project to the location I would like to put the file, which corresponds to a location inside the nested HTML-project. (But I did it inside the PHP/parent project, not the nested project.)
There I selected in the upper box for which project I want to create a file. (This was needed in order for Netbeans to offer a PHP file anyway.)
After that Netbeans jumped to the (other) project, not the project I selected for creating the file.
Comment 3 Milos Kleint 2013-01-14 09:41:38 UTC
IMHO invalid project setup, but reassigning to php for evaluation.
Comment 4 Tomas Mysik 2013-01-14 10:08:09 UTC

*** This bug has been marked as a duplicate of bug 224799 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo