Bug 224750 - com.sun.jdi.ClassNotLoadedException: Class java.lang.Class not loaded
com.sun.jdi.ClassNotLoadedException: Class java.lang.Class not loaded
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.3
All All
: P1 (vote)
: 7.3
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT
: 73_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-11 10:24 UTC by Jiri Kovalsky
Modified: 2013-01-16 12:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.89 KB, text/plain)
2013-01-11 10:24 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2013-01-11 10:24:01 UTC
Build: NetBeans IDE Dev (Build 201301100107)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-b18
OS: Windows 8

User Comments:
jkovalsky: Started debugging MemoryView Ant testing application, took its GUI snapshot, showed listeners on "Garbage Collect" button and then invoked "Set Logging Events..." action from "Event Log" node in "Events" output tab. Checked java.awt.event.MouseListener and clicked "OK".
Please note this is on Windows 8 with JDK 7 Update 10.

jrojcek: I used "Add Logging Listener" in the new GUI debugger. The exception occured after selecting an ItemListener and clicking OK button.




Stacktrace: 
com.sun.jdi.ClassNotLoadedException: Class java.lang.Class not loaded
   at com.sun.tools.jdi.ClassLoaderReferenceImpl.findType(ClassLoaderReferenceImpl.java:106)
   at com.sun.tools.jdi.ReferenceTypeImpl.findType(ReferenceTypeImpl.java:1156)
   at com.sun.tools.jdi.MethodImpl.argumentType(MethodImpl.java:162)
   at com.sun.tools.jdi.MethodImpl$ArgumentContainer.type(MethodImpl.java:263)
   at com.sun.tools.jdi.ObjectReferenceImpl.validateAssignment(ObjectReferenceImpl.java:584)
   at com.sun.tools.jdi.ObjectReferenceImpl.prepareForAssignmentTo(ObjectReferenceImpl.java:557)
Comment 1 Jiri Kovalsky 2013-01-11 10:24:03 UTC
Created attachment 130109 [details]
stacktrace
Comment 2 Jiri Kovalsky 2013-01-11 10:31:16 UTC
I think this is a P2 issue, because the feature (events logging) is not usable.
Comment 3 Marian Mirilovic 2013-01-11 10:43:18 UTC
Do we plan to fix it for 7.3 ?
Comment 4 Jiri Kovalsky 2013-01-11 10:51:06 UTC
If somebody else does not reproduce this on Windows 8, I do not insist on fixing this to 7.3. Your evaluation Martine?
Comment 5 Martin Entlicher 2013-01-11 11:19:27 UTC
I've reproduced the problem on Linux as well.
I'm going to investigate how to fix...
If this would be reasonably fixable, I'd vote for integrating the fix into 7.3.
Comment 6 Martin Entlicher 2013-01-11 14:38:48 UTC
It's a class loader issue.
I've fixed it in trunk changeset:   244363:47c8af772632
http://hg.netbeans.org/core-main/rev/47c8af772632

If it works well, I'd integrate it into 7.3, if approved.
Comment 7 Jiri Kovalsky 2013-01-11 14:48:09 UTC
Sure, I will verify the fix once a trunk build is available.
Comment 8 Quality Engineering 2013-01-12 02:53:08 UTC
Integrated into 'main-golden', will be available in build *201301120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/47c8af772632
User: mentlicher@netbeans.org
Log: #224750: Choose the VM application class loader to load the service classes.
Comment 9 Jiri Kovalsky 2013-01-12 12:22:47 UTC
Product Version: NetBeans IDE Dev (Build 201301120001)
Java: 1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-ea-b15
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/dev
Cache directory: /home/cesilko/.cache/netbeans/dev

Verified. Please integrate the fix to release73 branch. Thank you.
Comment 10 Jaroslav Havlin 2013-01-14 10:51:22 UTC
> Integrated into 'main-golden', will be available in build *201301120001*
> Changeset: http://hg.netbeans.org/main-golden/rev/47c8af772632
The change seems fine to me.
Comment 11 Martin Entlicher 2013-01-14 14:01:36 UTC
Upgrading to P1, since it's a showstopper.
Comment 12 Martin Entlicher 2013-01-15 10:44:20 UTC
Integrated into release73 branch: changeset:   251557:4aef10127e94
http://hg.netbeans.org/releases/rev/4aef10127e94
Comment 13 Quality Engineering 2013-01-16 00:01:14 UTC
Integrated into 'releases', will be available in build *201301152100* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/4aef10127e94
User: mentlicher@netbeans.org
Log: #224750: Choose the VM application class loader to load the service classes.
(transplanted from 47c8af772632fb47715143c6b4732de936606b33)
Comment 14 Jiri Kovalsky 2013-01-16 12:58:54 UTC
Product Version: NetBeans IDE 7.3 RC1 (Build 201301152100)
Java: 1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-ea-b15
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/7.3rc1
Cache directory: /home/cesilko/.cache/netbeans/7.3rc1

Verified in NetBeans 7.3 RC1 build #201301152100. Thanks for the fix.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo