Bug 224710 - ClassPathProviderImpl.getJsStubs is slow yet called many times for single indexed file
ClassPathProviderImpl.getJsStubs is slow yet called many times for single ind...
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Documentation
7.3
PC All
: P1 (vote)
: 7.3
Assigned To: Martin Fousek
issues@javascript
: 73_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 14:52 UTC by Petr Hejl
Modified: 2013-01-18 14:58 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2013-01-10 14:52:19 UTC
See subj. You can test it on project attached to issue #223237. This might be a regression.

I believe this fixes things in trunk:
web-main b29f4389304d
Comment 1 Martin Fousek 2013-01-10 15:13:14 UTC
Thanks Petr, that's important catch I think. Marking as stopper (P1) since the performance impact due to missing caching could be big and this code was included this week so it was not caught yet, but I believe that users could complain about that. Also there is almost no risk - just caching into static field.

> I believe this fixes things in trunk:
> web-main b29f4389304d

Fix looks well. Thanks a lot.

CCing Vlada for testing that. Vlado it could be quite difficult to differ between fixed and not fixed version since the file from #223237 is really huge and the editor reacts slowly. But when you will have IDE with the changeset #b29f4389304d, open the huge file and play with the navigator, threads in thread dump shouldn't stay on InstalledFileLocator any more.
Comment 2 Vladimir Riha 2013-01-10 15:28:58 UTC
Ok thanks. I'll test it once it gets into 73 build
Comment 3 Vladimir Riha 2013-01-14 08:02:11 UTC
I don't see InstalledFileLocator in thread dump and overall performance (also thanks to issue 224688) is way better. Verified. Please continue with HR fix integration


Product Version: NetBeans IDE Dev (Build 201301140001)
Java: 1.7.0_10; Java HotSpot(TM) Client VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Martin Fousek 2013-01-14 08:17:20 UTC
Marking as fixed since web-main #b29f4389304d.
Comment 5 Martin Fousek 2013-01-15 07:09:07 UTC
Fix transplanted into release73 branch in releases #b7420dd2f083.
Comment 6 Vladimir Riha 2013-01-18 14:58:07 UTC
Verified in RC1

Product Version: NetBeans IDE 7.3 RC1 (Build 201301172100)
Java: 1.7.0_10; Java HotSpot(TM) Client VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo