Bug 224688 - Long recursion during finding prototype chain
Long recursion during finding prototype chain
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
7.3
PC Linux
: P1 (vote)
: 7.3
Assigned To: Petr Pisl
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 10:06 UTC by Petr Pisl
Modified: 2013-01-15 09:00 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Reproducible in this file (951.73 KB, application/javascript)
2013-01-10 10:08 UTC, Petr Pisl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2013-01-10 10:06:21 UTC
Some times the ide crash with OOM Exception. From the thread dump it's clear that resolving prototype chain can be never ending:

at org.netbeans.modules.javascript2.editor.model.impl.ModelUtils.findPrototypeChain(ModelUtils.java:838)
	at org.netbeans.modules.javascript2.editor.model.impl.ModelUtils.findPrototypeChain(ModelUtils.java:838)
.....

Still the same line.
Comment 1 Petr Pisl 2013-01-10 10:08:51 UTC
Created attachment 130069 [details]
Reproducible in this file

It can be reproducible in the attached file.
Comment 2 Petr Pisl 2013-01-10 10:10:58 UTC
This is showstopper for NB 7.3
Comment 3 Petr Pisl 2013-01-10 10:23:28 UTC
Fixed in web-main:
http://hg.netbeans.org/web-main/rev/c9ab1248b1f0

Could I ask QE for verification? Thanks
Comment 4 Petr Pisl 2013-01-10 10:32:15 UTC
Petre, could you please review the fix. Thanks.
Comment 5 Petr Hejl 2013-01-10 10:35:29 UTC
(In reply to comment #4)
> Petre, could you please review the fix. Thanks.

The fix seems to be ok.
Comment 6 Quality Engineering 2013-01-11 03:02:22 UTC
Integrated into 'main-golden', will be available in build *201301110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c9ab1248b1f0
User: Petr Pisl <ppisl@netbeans.org>
Log: #224688 - Long recursion during finding prototype chain
Comment 7 Vladimir Riha 2013-01-11 10:50:06 UTC
I'll try it later today
Comment 8 Vladimir Riha 2013-01-14 09:34:09 UTC
Verified, seems OK


Product Version: NetBeans IDE Dev (Build 201301140001)
Java: 1.7.0_10; Java HotSpot(TM) Client VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)
Comment 9 Petr Pisl 2013-01-14 16:04:15 UTC
The fix transplanted into releases73 branch: http://hg.netbeans.org/releases/rev/f860f8e3d751
Comment 10 Quality Engineering 2013-01-14 23:58:03 UTC
Integrated into 'releases', will be available in build *201301142100* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/f860f8e3d751
User: Petr Pisl <ppisl@netbeans.org>
Log: #224688 - Long recursion during finding prototype chain
Comment 11 Vladimir Riha 2013-01-15 09:00:06 UTC
No issue found in RC1, verified

Product Version: NetBeans IDE 7.3 RC1 (Build 201301142100)
Java: 1.7.0_10; Java HotSpot(TM) Client VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo