Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 224467 - jvi plugin stops irregularly functioning.
jvi plugin stops irregularly functioning.
Status: RESOLVED WORKSFORME
Product: third-party
Classification: Unclassified
Component: -- Other --
7.2.1
PC All
: P2 (vote)
: TBD
Assigned To: err
issues@third-party
:
Depends on:
Blocks: 179047
  Show dependency treegraph
 
Reported: 2013-01-04 10:44 UTC by t.grinwis
Modified: 2013-03-25 18:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description t.grinwis 2013-01-04 10:44:32 UTC
I am addicted to use vi when developing code. In other words when vi mode is
not working I cannot use the editor efficiently (even thinking about change
ide!!).
For using netbeans the jvi plugin is very important.

Recently I discovered that suddenly de vi mode stopped while the jvi checkbox
was on in the tools menu. I do not remember it exactly but it started from
using vesion 7.1 or 7.2

Normally one can solve this by un-check, check the check box in the tools menu,
and jvi is working again. This happens when eg a change in the tools->options
key bindigs is done.

Lately we change to use GIT in our SCM environment. I discovered that the vi
mode is now disfunctioning more times.

To resolve this vi mode disfunction I have to remove my netbeans settings
~/.netbeans/<version>

Then restart netbeans, install my plugins again and import my options.

this is of course very annoying. 
When it happens once a week, no problem, but several times a day ....

I cannot recognize if the problem is in the jvi plugin or netbeans ide.
Comment 1 Ondrej Vrabec 2013-01-04 10:53:22 UTC
t.grinwis: i think you should file the bug directly to the jvi plugin - http://jvi.sourceforge.net/
Comment 2 err 2013-01-04 17:16:58 UTC
Bug was filed: https://sourceforge.net/tracker/?func=detail&atid=103653&aid=3599439&group_id=3653

Will keep this NB issue open until it is clear that the problem is not NB. Since there have been no other reports of this behavior, my suspicion is that there are exceptions causing the problems.
Comment 3 t.grinwis 2013-01-05 01:18:02 UTC
added comment to jvi issue below:
https://sourceforge.net/tracker/?func=detail&atid=103653&aid=3599439&group_id=3653
Comment 4 t.grinwis 2013-01-05 22:26:36 UTC
Re-installing netbeans 7.2.1 now together with the Jdk 7 bundle and
not importing my options but re-doing by hand seems to solve the problem.

I would suggest to not ( or postpone) to put more effort in this ticket
until the problem rises again.

Thanks in advance for your cooperation.
Comment 5 err 2013-03-25 18:56:02 UTC
The user got rid of the problem by a clean reinstall and not importing all settings. It's been almost 3 months without the problem reoccurring and no other reports. Closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo