Bug 224294 - AssertionError: rename folder from Send -> smthng -> send fails
AssertionError: rename folder from Send -> smthng -> send fails
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-28 22:05 UTC by Exceptions Reporter
Modified: 2013-08-20 12:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.90 KB, text/plain)
2012-12-28 22:05 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-12-28 22:05:49 UTC
This bug was originally marked as duplicate of bug 185346, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-b18
OS: Windows 7

User Comments:
GUEST: I try to rename folder from "Send"  to "send" with no result. Then I try to rename to some other name -- folder was renamed. But I can't rename this folder again to "send" -- this error occures.




Stacktrace: 
java.lang.AssertionError: childName: C:\Www\Crm\nbproject folderName: C:\Www\crm
   at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.addChild(ChildrenSupport.java:135)
   at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.rescanChildren(ChildrenSupport.java:265)
   at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.getChildren(ChildrenSupport.java:89)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj$FolderChildrenCache.getChildren(FolderObj.java:677)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.computeChildren(FolderObj.java:173)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getChildren(FolderObj.java:155)
Comment 1 Exceptions Reporter 2012-12-28 22:05:51 UTC
Created attachment 129748 [details]
stacktrace
Comment 2 Jaroslav Havlin 2013-08-20 12:04:18 UTC
I'm sorry, I cannot reproduce the bug.
Please, can you try to reproduce it in the latest development build
and reopen the issue if the bug is still valid?
Thank you.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo