Bug 224281 - 2.3s - CodeCompletion accessing disk
2.3s - CodeCompletion accessing disk
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.3
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-28 14:56 UTC by misterm
Modified: 2013-01-08 08:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (13.47 KB, application/nps)
2012-12-28 14:56 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2012-12-28 14:56:49 UTC
This bug was originally marked as duplicate of bug 223180, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 20121220-4f53a116c76b)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7
Maximum slowness yet reported was 2318 ms, average is 2318
Comment 1 misterm 2012-12-28 14:56:51 UTC
Created attachment 129742 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2013-01-08 08:47:24 UTC
1 call to 
org.netbeans.api.java.classpath.ClassPath$RootsListener.addRoots()	100.0	1,538 ms (100%)	1,538 ms	1
yields one to 
org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getChildren()	99.39461	1,529 ms (99.4%)	1,529 ms	1
which then touches the disk multiple times
org.netbeans.modules.masterfs.filebasedfs.utils.FileInfo.isDirectory()	81.28346	1,250 ms (81.3%)	1,250 ms	8

Probably won't fix. Especially if it takes just 3s.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo