Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 224107 - Show relative path to project root in search results
Show relative path to project root in search results
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Navigation
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 21:58 UTC by hosiplan
Modified: 2012-12-22 02:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
search results (12.74 KB, image/png)
2012-12-20 21:58 UTC, hosiplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hosiplan 2012-12-20 21:58:16 UTC
Created attachment 129597 [details]
search results
Comment 1 Ondrej Brejla 2012-12-21 07:21:11 UTC
I think that this enhancement somewhere already is, but dunno where. Will look at it. Thanks!
Comment 2 Ondrej Brejla 2012-12-21 10:05:46 UTC
It has been fixed in infrastructure, you can resize that result window. I think that it's ok, isn't it?

*** This bug has been marked as a duplicate of bug 220468 ***
Comment 3 hosiplan 2012-12-21 10:08:25 UTC
You're right I can do that. But it's pretty ugly :)
Comment 4 Ondrej Brejla 2012-12-21 10:16:00 UTC
Ok, I'll look at it once again ;)
Comment 5 Ondrej Brejla 2012-12-21 11:30:34 UTC
Instead of full path I can show there project name, where the file is located and relative path to that project root directory.

I.e.

DefaultRoute in \Routers\DefaultRoute in TestingProject ./foo/DefaultRoute.php
Comment 6 hosiplan 2012-12-21 11:40:06 UTC
Sounds great :)
If it's inside class, there should be classname.
If outside class, than filename.
What do you think?
Comment 7 Ondrej Brejla 2012-12-21 11:44:37 UTC
I think that it should be consistent for all files and indexed elements.
Comment 8 Ondrej Brejla 2012-12-21 11:48:49 UTC
And if it's inside a class (or some type name), then that type name is displayed after the first " in ". In my example, it's "\Routers\DefaultRoute" part. if it's not inside a FQ type, then there's no middle part with " in FQ\TypeName", just " in some/FileName.php". I think that it's ok.
Comment 9 Ondrej Brejla 2012-12-21 13:09:16 UTC
Fixed in web-main #63c810eb3cca
Comment 10 Quality Engineering 2012-12-22 02:29:24 UTC
Integrated into 'main-golden', will be available in build *201212220001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/63c810eb3cca
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #224107 - Show relative path to project root in search results


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo